Ropieee not detected in HQplayer but Spotify connect working

Recently, I had upgraded my router provided by the ISP. After upgrading I no longer able to find the device in my HQplayer, had tried looking at port forwarding and adding inbound and outbound rules. After doing all that, it still does not work

For sure all ip addresses have changed, did you check them?

for the port forward?, yes i redo it since its a new router

Not for port forward, likely changing the router the subnet changed too and ip addresses changed too, for example:

  • the previous router had 192.168.0.1 as address and the subnet was 192.168.0.x
  • the new router can have address 192.168.1.1 and consequently the subnet is 192.168.1.x

This could be important if you had defined fixed ip addresses with the old router.
It is anyway better to reboot everything on the network to let the diverse assume new addresses, dns and subnet according to the new router it you’re using dhcp

The router address is still the same, the ropieee also got a reflash. At this point I felt like I have nothing that I can do anymore

Are you running HQP on Windows? Check then the Windows network type, it should be Private and not Public

Yep it’s on windows, I had it on private, before this , I had issue with syncing with the hqplayer control app on the phone. Putting it to private connection did the job, now I can sync but no device in the output.

Have you tried to reboot HQP pc? (Or just restart HQP)

Yes, it’s in my daily pc. So it’s always turned on and off.

If anyone has any idea, please do suggest things that I can do

Make the test as simple as possible: disable all other services, so only HQP NAA is enabled and the rest is disabled.

And just to be sure: your HQP server and RoPieee endpoint are on the same subnet?

Tried disabling all services except hqplayer and it doesn’t work. And yes the subnet is the same

Can you send me feedback? You can find that option on the ‘advanced’ tab.

sent, its 697d83c608059df2

Hi,

There’s something strange going on with your network.
The first thing that I noticed is that you don’t have a hostname set, it’s empty!
Please don’t do that (I should make it impossible to do that), but give your unit a proper hostname (default is ‘ropieee’) and try again.

Thanks

I have entered the hostname and its still the same, it could not detect the device of the ropieee

Can you send me another feedback?
What’s the IP address of your HQP server?

the feedback is f6410cf71ab5a588 and the ip is my computer which is 192.168.0.109

Can you disable Spotify for now?
It’s causing a lot of ‘noise’ in the logs (you’ve entered the wrong credentials, that’s at least what the logs say).

Furthermore the network error message from NAA has gone, so I would expect HQP to pick it up again…

still the same, I have sent another feedback 49472a1ea79f4de5