Ropieee Not Found in Roon

Hello all,

I have just made my first Raspberry pi based endpoint, but am having some troubles connecting to it. Here’s the rundown of my trial and error for context:

So last night I assembled it, flashed the card with Raspbian (in order to set up the onboard wifi), then flashed the card with Ropieee as per the “Beginner’s Guide”. Plugged it in to my DAC, found the endpoint in Roon - Perfect! Everything playing loud and clear, wirelessly, from my Macbook being used as a core. This morning, same story. Played several albums in a row, over the wifi, no problem.

So I know at the very least, I configured the Pi’s onboard wifi correctly, because of these successful tests. Later this evening, however, Ropieee cannot be found in Roon, despite several reboots of both the Pi itself, and the Roon core. Hours later, still no luck.

Fine. I decide to reflash the card entirely. A complete flash of Raspbian again, setup the wifi, a complete reflash of RopieeeXL (I went with XL this time just to see if it would make a difference). Set it back up, still cannot be found in Roon, despite it showing RopieeeXL as “online” when scanning my network for devices with the Fing app. When I tried wiring the Pi to my router (which is far away from my soundsystem) via ethernet, it showed up in Roon, but it’s useless to me there.

I’m confused as to how this endpoint could work for the past two days, quite reliably, and though nothing has changed, it’s just vanished from the network. I understand that everything works better if it can be wired in via ethernet, but where I live, it’s simply not possible to run cable from the router into my sound room. Plus, I feel that kind of defeats the purpose of the portability of these Pi-based units, no?

This is my first endpoint ever, I finally got Roon’s awesome software away from my laptop and onto my sound system, but now I’m just feeling pretty discouraged. Just wondering if I am missing something here and what else I can do to troubleshoot? Any tips would be greatly appreciated.

Here is my configuration:

  • Macbook Pro 2018 as Roon Core. All software up to date.

  • Playing only native files from local library.

  • Latest Roon Build 571

  • Raspberry Pi 3 B+

  • with Allo DigiOne HAT

  • running Ropieee XL

  • connected to Schiit Modi 3 DAC

  • via USB (I don’t have the proper cables to use the DigiOne’s spdif to the DAC yet)

In the Ropieee GUI, I do have the USB DAC connection selected. Also the wireless is enabled, with the correct Network and password.

All you do it flash the card with RoPieee or RoPieeeXL. Connect using ethernet and let RoPieee do it’s thing. Then, find the IP address and log into the RoPieee software using your browser. Choose your settings including WIFI. Save and reboot. Then, you can disconnect ethernet and use WIFI.

This serves no purpose whatsoever as a flash and install of Ropieee overwrites everything you did prior.

I suggest you follow Nathan’s very good guide here

adding wifi in the network settings is a last step and must be completed before disconnecting the pi from ethernet.

Thanks, Jim.

Perhaps I didn’t phrase myself correctly. I did exactly that. The wifi worked, music was playing on my system for a couple days, no problems at all. Next time I went to use it, Roon cannot find it as an endpoint. So after a few reboots with no change, I did the whole setup again, flashing the card, just to be sure, re-configuring the network settings via the Ropieee software. But I’m still having no luck in getting Roon to “see it” as an endpoint.

Thanks for the reply.

I figured Raspbian would get ovewritten, but i did it just incase. I did the whole setup exactly per that guide, and had it working on my first boot. Playing music for two days in a row, long hours, high traffic, no problem. Suddenly it stopped being visible in roon tonight.

Rebooted Pi and Core several times, no luck. So I went re-installed Ropieee all over again, just incase. Exactly as per the guide.

But I’m still having no luck in getting Roon to “see it” as an endpoint. I’m just perplexed as to how to troubleshoot next. I’ve tried taking the endpoint to all other parts in my house, even right beside the router, it’s still not “recognized” by Roon over wifi.

You wont see the endpoint (or ropieee) if the DAC is not powered up and available.but it should be visible in the about section of roon settings showing the Roon Bridge instance

if its a HAT maybe could be a power issue 2.5A 5V minimum or a settings issue (HAT not specified correctly) in ropieee

Have you tried it using an ethernet connection?

Here’s what I see. Meridian Prime is a wired RPi4. Dragonfly is a WIFI RPi4.

Thanks for the suggestions everyone. I just tried re-flashing for the second time. Re-configured settings as per the guide, same as I did the first time.

DigiOne shows up immediately in Roon, as does the Modi 3 DAC when ethernet is plugged in. Immediately disappears when unplugged - so it’s clearly an issue with connecting to the network.

I don’t understand how I got the wifi to work earlier this week and now, nothing. So either I’ve done something wrong or the wifi on the pi itself went bust?

@spockfish I just sent you feedback: c6472ecc43a6bfa4 . I’d appreciate any insight!