Ropieee not showing up in audio

Hi, I can use the ropieee with airplay but not directly via the Roon controller.

I sent feedback and it asked me to leave a note here but I’m new to all this so hope I’ve put it in the right place.

My Roon core is on a synology ds920+ and I’m using my iPhone as the controller.

Any help would be greatly appreciated.

3e6e1fe623f7d9f9 is the number I was given.

Is the RPi on the same subnet in the network?
Is the hostname set in the web UI for the RoPieee?
Is the RoPieee showing up in Settings/audio (or in setting about)? If it is in settings audio, is it enabled?

Hi thanks for the reply, they’re both connected to the router via Ethernet.

I’ve left the host name as ropieeexl and it shows up in settings but is greyed out. I have taken a screenshot to explain a little better.

Can you show a screen shot of settings/about?

Have you checked the IP address on the ropieee webui to make sure it is in the same subnet?

Do you have an audio HAT on the ropieee and is it enabled on the webUI?

Hi I think this is what you mean.

I don’t have any hat as the ropieee goes straight to my dac via usb.

Can you access the Ropieee webui?
You need to either know what the IP address is of your RoPieee or you can visit http://ropieee.local (or http://ropieeexl.local for RoPieeeXL)

Is Audio USB enabled in the web UI? Also make sure the DAC is on for it to show up in Roon.

I’ve moved your post into the appropriate category “Ropieee” under “Audio Gear Talk”.

1 Like

Hi bear, yes I’m able to access the ropeee through the browser and usb audio is enabled. I’m able to play audio and it’s coming through the dac but only at 44.1khz no matter what I play.

So your DAC is connected and powered on, but still no sign of it…
Which DAC is it?

Here’s a photo from the gui in the browser

I’m not a XL user, but don’t you have to switch modes from Bluetooth to Roon in Ropieee’s Web UI?

I have the audiolab mdac+ I’m able to play files from the nas and also Qobuz but everything is downsampled

I just installed XL to test it out, on a RPi 4 and did not have to do anything for it to show up.
Got a second Roon Bridge in about and it shows up in Audio, just had to enable it in audio to get it working.

@John_read1 The screen shot looks like it should be working. just to confirm DAC is on and plugged into the USB? What are the lights on the RoPieee doing? red light on steady? Green light should be flashing about once per second. Might check firewall settings? Not sure what else to suggest here. hopefully @spockfish will get the feedback when he can and give you a hand?

@John_read1 There’s a problem with Roon Bridge not properly installed.

This has been fixed by Roon last Friday (gave them a hint :wink: ), but for some reason it’s still failing on your end.

Is there a reason you went with XL? Because I’m curious if it works with ‘regular’ RoPieee…

And can you reboot once again? RoPieee tries to fix the issue upon boot.

1 Like

I have also been having an issue with XL not showing up as an endpoint. Tried rebooting everything, reflashing the SD card. Now trying regular Ropieee.

Here’s what I see…

It may be a Roon bridge issue - I had airplay earlier working on Ropieee, but not RAAT. I have just tried Volumio and it is hitting issues with Roon bridge. Tagging @support in case it is a larger issue

I will try that, initially I went with ropieee but couldn’t get that to show up at all so decided to give xl a go and that showed up but I’m aware that’s because xl has airplay support so I went back to the normal version and it doesn’t show. I noticed a yellow tab saying reinstalled Roon bridge so I hit that and still a no show. I will try rebooting again this evening. Thought I should add that each time I’ve changed versions I have formatted the sd card and re flashed.

Ok, did a reflash with the latest RoPieee production image (2022.03).

I’m wondering if this is a caching/CDN issue: Friday the Roon team provided a new Roon Bridge installer script, but I see a few people still having these issues.

Anyways, just reboot and RoPieee will try again.


So - might be a Roon issue - as I am having issues with Volumio showing up as well. Airplay shows up fine.