RoPieee on Raspberry Pi 4

That is true.

I just (almost) finished a RaspTouch w official 7" touch screen, RPi4 2G and Hifiberry DAC+ Pro.
Driving 4" nearfields with vintage TEAC integrated.
Thought Ropieee a bit involved to install till I tried some others.
Back enjoying music rather than the command line interface.
This is a musical hobby for me.
Have PI and DAC individually powered on dual DC inputs., have DAC’s analog out hardwired to rear jacks., bypassing clumsy internal patch cord.
Wishing Ropieee would take the steps in code to integrate the Audiophonics Power Module for sleek on/off with LED indicator.
This chassis has a nicely integrated flush power switch.
Been in hifi since mid 70s. Really like this Ropieee/Roon setup.
One I got past the phone stuff:)’

1 Like

Hello,
I also have a pair of RaspTouch Roon endpoints with ropieee in use and had the same problem. The power button (momentary switch from Audiophonics). I replaced it with the same type of vandalism proof SPDT (or DPDT) on/off switch, so a choice for hardware shutdown. This poses no problem in contrast to the normal Debian derived images on an SD card because ropieee runs exclusively in RAM and so there is no risk of corruption of the SD card during the shutdown because nothing is saved to the card.

Greetings,

That’s one of the reasons why I use Ropieee, yet today I discovered that the SD card had got corrupted, and I had to flash a new one to get my endpoint back. The RPi4 power adaptor is on a timer that removes power between midnight and 8am every day. Could this have caused the corruption?

What was really the problem with the SD card, file system corruption or a hardware failure? If it were just a file system problem, I would assume the card could just be reformatted or reflashed, but you say you had to use a new card…

I had a spare card, so I just used that. Here’s more background on the event:

Yes, I had read that thread. I thought that maybe after restoring your Pi4 you would have tried to re-flash the problematic card, just to make sure if it was definitely damaged or if it could be reused.

I would assume this to be a card failure rather than a file system corruption. If it is true that RoPieee runs in RAM and does never write back to the card, then power cycling the Pi4 should never result in file system corruption. Thinking about that, I have never tried to write-protect the SD card in my Pi4 after flashing it… that would go to show that there is definitely only read access to the card during normal operation.

What I do wonder is if the repeated power cycling could eventually induce hardware failure in these cards. I leave my Pi4 running all the time, but have to deal with frequent power outages. So, at the end it too gets power-cycled more often than I would like.

Keep in mind that although RoPieee does not write to disk during operation, obviously stuff is written when you change a config option for example.

And for the more tech savvy: RoPieee does not mount stuff RO. Although I’ve got stuff lying around that mounts it RO and remounts whenever it needs to write to disk, I’ve never found the time to finalize this. But I run my units fairly regularly in RO to make sure that there isn’t something ‘leaking’ somewhere.

And finally… there’s the topic of SD cards. They tend to have … a limited lifetime :wink:

In general: if you want to go for maximum stability: don’t power the units down.

regards Harry

4 Likes

Yup, probably the best advice. And there’s me trying to do my bit for the planet…

3 Likes

I am NOT using Audiophonics power module or switch.
I restartde the PC and both phone and PC only display black screen with logo dancing at center.

@spockfish does a reboot do basically as a power down then up? and if so will this also cause lifetime impacts on the SD? I reboot/restart my units nightly on the beta channel, maybe I should change that to weekly?

Hello and sorry if I am bit out of the subject.
First congrats for what you did, it is marvelous and I bought 2 raspberry touch to get along with Ropeee xl.

I have just one quick question
The first RPI4 works fine as an endpoint and touchscreen is ok.
The second one with same config and same products works fine displaying albums and so on Except touchscreen does not work and no way to « play » with brightness.
I have no need for another endpoint as the purpose of this one is to display albums played on my Bluesound flex
What do you think could come from?
Config on Ropeee local Or need to re install?
Cheers and again bravo!!

The official 7" Touch display is looked up at the very first boot of the ropieee and then initialized. Adding it afterwards is not a good idea.
Using a display and it doesn’t seem to work?
Make sure you are using the official Raspberry Pi 7” Display, and make sure that it is connected during the initial software install (if not, simply re-flash, restart from scratch)

Greetings,

Thanks but that is a ready to use solution I bought on Amazon with everything already in place.
Official display, RPI4, psu etc…
I just have to flash sd card and get Ropeee xl.

Everything is fine on both products except that on second one no touchscreen capability.
I ll try to re install ropeee and let you know

Thanks,

I guess it’s possible your touchscreen is defective. If it doesn’t work properly after a reflash of RiPieeeXL, that would be my guess.

Yes i am afraid so…
I am trying to re install it now.
It won’t be a big deal if touchscreen does not work, it is just I would like to play with brightness.

If the reflashing (don’t try to reconfigure) of an sd card doesn’t succeed, unfortunately it’s time for a hardware troubleshooting : buying a device assembled is no guarantee that it will work (RPi is mainly meant for DIY, the low budget derivatives can hardly have an efficient quality control) . Assembly errors are first and foremost the connectors for the flexcables (flexfoil) with a weak lock which causes traction on the cable to loosen the contact points. The LCD display has two on its own PCB board and then another connection to the RPi : plenty of choice to detect errors by opening the connectors and firmly reconnect the flexcables.Those connectors have different types of contact surfaces so it’s wise to make sure the correct contact points coincide, but Youtube can help with the assembly, a solid loupe as well.

Greetings

Thanks for the tips
I feel confortable to open and try reconnect
I have always built my pc’s.
I asked the question just in case it was config matter
I ll let you know as soon as I am home.

As usual forum is helpful!

Good idea. Those ribbon cables seem problematic to me. Make sure it is plugged in all the way and the little plastic locking device is secured.

image

Guess what? Touchscreen was disconnected…
Thanks for your help!!!

I’ m now a happy user of two raspberry touch for my roon set up😬

3 Likes