Ropieee on rpi4, endpoint dropping out of Roon on pressing play

I just put together a RPI4 yesterday with USB out to my Arcam irDACII. I had no problem with the build and its installed in metal case and temps, reported by ropieee are, around 40 - 44c. All good…

However yesterday, when in Roon, I went to ‘settings’ and then ‘about’ and I could see the endpoint, but it took a while before I could see in the ‘audio’ part of settings, but after rebooting the core and generally fiddling, I managed to see the endpoint. However, when I then pressed play, it played for a second and then the endpoint dropped out completely and was again no longer visible in the ‘audio’ part of Roon however it remained visible in ‘about’. I could also still login into Ropiee via the webpage. Cue, lots of rebooting and finally, I could see it again. I actually changed to the USB 3 port at this point. Anyway, I played some music last night, so all good.

This morning, I tried to play again, and the same thing happened again; maybe a second of music, maybe less, and then the endpoint dropped again and was no longer visible in ‘audio’ but I can still see it in ‘about’.

Any ideas? Could this be a hardware issue? Software? Any thoughts @spockfish? or @support?

I just tried gentooplayer and interestingly exactly the same thing happened, as in, all recognised in Roon, I pressed play and the endpoint died. I am using the official psu, so it should have enough power. Faulty rpi? Faulty PSU? Dodgy cable?

I am going to reboot, and swap some cables around and see if that helps.

Can you send me feedback? You can find that on the ‘advanced’ tab in the web interface.

Thanks @spockfish. I have swapped the usb cable at the same time as having another go with gentooplayer. Its playing right now, but much the same happened with ropieee yesterday. I will see what happens over the next 24 hours, and if it falls over again, I will go back to ropieee (it was my preference) and send you the feedback.

Thanks again.

So the problem is back, or still there. After loading Gentooplayer (just using roonbridge, nothing else) I used the endpoint all day yesterday (rpi4 into irDACII) with no problem at all, in fact I rebooted the streamer loads of times as I was trying different kernels.

The streamer has been on all night, I usually leave on my streamers. When I opened Roon today, I let the new updates run, I could see the endpoint, then I hit play and at that point I lose the endpoint out of Roon. However the rpi4 is still working, it hasnt crashed, I can access Gentooplayer via its web interface. Also, in Roon, in ‘about’ I can still ‘see’ Gentooplayer, but I cannot enable the endpoint in Roon as its missing in ‘audio’. I have tried rebooting the core, the rpi4 etc but I still cannot see the endpoint.

Edit - I just tried rebooting the DAC (after rebooting everything else) and that seems to have helped and I can see the endpoint again.

What is going on to drop the endpoint each morning? @support, any thoughts?

Hello @Ross,

If you could clarify—when then device is in the broken state in regards to Roon playback, are you able to successfully play to the DAC using gentooplayer?

It will be difficult to determine what’s going on here without logging information… Once @spockfish has had a chance to take a look he is invited to share the raat logs with us for further analysis.

-John

Hi @john - The situation seems to be the same irrespective of whether I am using Gentooplayer or Ropieee.

Normally the rpi4 stays on all the time, and the DAC is switched off at night and on again in the morning. Then, occasionally, when I try and play to that endpoint for the first time that day, its at that point that the endpoint just drops off. However, if I turn the DAC back off and on again, the endpoint re-appears, and this seems to be the case for Gentooplayer and Ropiee. Also, for clarity, I have been doing this exact behaviour, DAC off at night and then on again in the morning but with a Allo Digione, also using ropieee (and dietpi in the past) and I have never seen this bahaviour. So, the only common factors appear to be the rpi4 and Roon.

How do we go about getting logging info?

Hello @Ross,

There should be a “Send Feedback” button in the “Advanced Settings” in the Ropieee WebUI. This will send logs to the RoPiee developers.

As an aside—Based on the symptoms you are reporting, it is likely that this is a hardware incompatibility between the Arcam DAC and the Raspberry Pi 4.

-John

I am having this exact problem, as well. It happens on all three of my Rpi (2 3+'s and a 4). All have a Ropieee fresh install. I can make the problem completely go away when I hardwire connect the Pi to the router. So I assume it is a Rpi WIFI problem. Not sure what happened to make the WIFI have problems. As Ross noted, the Ropieee webpage still works but it is really slow and prone to failure to load. My other WIFI devices (MiniDSP SHD and Chromecast Audio) work without a single hiccup. So, I don’t believe it is my Eero MESH system having problems.

The last time I had this problem I switched to DietPi and was problem free. Later, I switched my WIFI system to the Eero MESH WIFI setup and tried Ropieee again and it worked without a hitch until just a few days ago. I’ll try DietPi to see if things go better on WIFI.

I am now embarrassed. It was a far easier solution than I had thought. After loading DietPi, which is a tedious process in comparison to Ropieee, I was able to get everything up and running and noted the same halting of play. However, I had the TV displaying the Dietpi screen and noted “under voltage noted” on the screen. I looked at the fine print on the power brick I was using and it was the wrong one. I had accidentally grabbed a lesser USB brick and it was failing to provide adequate current to the raspberry Pis when Roon started playback.

Tested it a few times with proper USB brick and everything is back to normal.

Foolish mistake for me. Perhaps you are having a similar issue? The lesser brick stated proper current and voltage for feeding a Rasp Pi but clearly was not meeting the spec.

Hi @Papi_Chulo, well at least you sorted it fairly quickly!

I am using the official rpi4 power brick, so I suppose it shouldnt be an under voltage issue. I had hoped I could use my existing Ifi version but it does not deliver quite enough power. Funnily enough, I havent had this problem for a while (famous last words) but a restart of my DAC, just flicking a switch off and on, usually sorts it. I am still on Gentooplayer, and have stuck with it as it has been working but it was not really any different than ropieee.