Ropieee on the New Raspberry Pi 4

Great - I just placed the order. Now I have a Pi 4 and NUC to set up over the Christmas break!!

Ho Ho Ho.:grinning:

2 Likes

I’m going to build an i9-9900 Fanless beast to run roon, jriver and audirvana plus Fidelizer and throw it on a Linear mode power supply. I might even stick an extra m.2 ssd in there and try it with ROCK

Hi Thomas. There is a firmware issue with the Sprout and Linux compatibility. The guys at PS Audio will ship it back and do the firmware flash for you, get them to do the flash that stops the very slight buzz you can get when you hit power as well.

Yes! I had that done already. Fantastic customer support by PS Audio - they even paid for shipping both ways.

They were awesome. Love the Sprout as well.

@spockfish

Just a question as I can not figure out what have changed here.
I just got the new RPi 4 4GB version.
So installed this into my RaspDAC Mini which has the ES9038Q2M DAC HAT.
Its powered over GPIO same as it was with older RPi3 B+
So now the Roon finally recognise this DAC properly and its set to I-Sabre Q2M DAC and in Advanced the correct sampling rate and DSD is available


But now there is this strange behaviour. The volume gain so so much lover than with the RPi 3 B+ for some reason.
With the older RPi 3 B+ I needed to have volume control to be set to Twenty to for my normal listening volume. With new RPi 4 I have to rock it up to Twelve O’clock or higher.
So very significant difference.

Any idea where the difference is?

Some info which may help you to troubleshoot

Blockquote
Software

Package Version
ropieee 20191226-1
ropieee-web 20191229-2
ropieee-extensions 20190407-1
mosquitto-ropieee 1.6.3-1
lirc-ropieee 0.10.1-8
inputlirc-ropieee 30-2
linux-raspberrypi-pae 4.19.89-1
qt5-base-ropieee-pi4 5.12.4-1
ropieee-remote 20190731-1

aplay -l **** List of PLAYBACK Hardware Devices **** card 1: DAC [I-Sabre Q2M DAC], device 0: I-Sabre Q2M DAC i-sabre-codec-i2c.1-0048-0 [I-Sabre Q2M DAC i-sabre-codec-i2c.1-0048-0] Subdevices: 1/1 Subdevice #0: subdevice #0

aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=DAC
    I-Sabre Q2M DAC, I-Sabre Q2M DAC i-sabre-codec-i2c.1-0048-0
    Default Audio Device

Thanks in advance

The only thing I can think of is that with the Pi 4 a different driver is being used. On the Pi 3 an older kernel is used that does not have the native driver hence it uses the generic RPI-DAC driver.

Thx for quick reply.
Is there anything that can be done with this maybe?
Is there alsamixer or similar to adjust settings?

The mixer is set to 100. But then again, this HAT is not the most easy one wrt software. Ahum.

You could have a look at the mixer settings (alsamixer).

Very strange thing just happened. I have pot the case back and all together.
Reboot the device and all is as before.
I have rebooted device before when I was testing it and nothing changed.

Will test it extended and report back if anything change

OK, so I am back again
All was playing nicely. I was playing some DSD files. Than I click on another album, in different format(WAV). Now the sound is back to ‘very quite’
Here is ticket a936f59438b328a0 maybe you can see something in it?

Not sure if this is going to be helpful, but this is output from end of the dmesg

[    3.161946] snd-rpi-i-sabre-q2m soc:sound: snd_soc_register_card() failed: -517
[    3.194253] bcmgenet: Skipping UMAC reset
[    3.195345] bcmgenet fd580000.genet: configuring instance for external RGMII (no delay)
[    3.212546] snd-rpi-i-sabre-q2m soc:sound: ASoC: CODEC DAI i-sabre-codec-dai not registered - will retry
[    3.212570] snd-rpi-i-sabre-q2m soc:sound: snd_soc_register_card() failed: -517
[    3.263371] snd-rpi-i-sabre-q2m soc:sound: Audiophonics Device ID : 00
[    3.263938] snd-rpi-i-sabre-q2m soc:sound: Audiophonics API revision : 01
[    3.264699] snd-rpi-i-sabre-q2m soc:sound: i-sabre-codec-i2c.1-0048 <-> fe203000.i2s mapping ok
[    3.795451] random: crng init done
[    3.795468] random: 7 urandom warning(s) missed due to ratelimiting
[    4.241754] bcmgenet fd580000.genet eth0: Link is Down
[    8.401773] bcmgenet fd580000.genet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[root@ropieee ~]# ^C

Looks there is an problem to load the card and needed few attempts to load it

That’s something that happens more often, so I don’t see a problem with that.
Have you checked the mixer settings?

1 Like

Ah, OK. Did not know that.
How do I check mixer?

alsamixer
cannot open mixer: No such file or directory

ok
alsamixer -c DAC


Now the volume is very low again once I entered alsamixer and I can not change values. Nothing seems to work

[root@ropieee ~]
# alsactl restore DAC
alsactl: set_control:1461: Cannot write control '2:0:0:Digital Playback 
Volume:0' : Remote I/O error

EDIT:
Another finding is that to get the sound back I need to select different card(no matter which) following reboots. Ten select I-Sabre DAC back. This seems to fix the sound. But it seems its not permanent as this may get ‘mute/quiet’ in some time again.

What you can try is switch back to the RPI-DAC generic driver.

@spockfish
No sound at all when I changed to RPI DAC

Now when the sound is low/quiet, I check the /var/lib/alsa/asound.state the value is set to 68 for DAC

So changing the value manually to 100 fix the sound

Now you enter alsamixer and try change volume from within, sound level drop instantly and you are stuck on it. You can not do anything until you manually edit asound.state file again and reboot

I have no clue what is going on here and why this is happening

this is extremely weird…

So, after you changed the volume to 100, and then reboot, what happens then with the volume?

After that sound is OK, play as it should.
But if you try check settings in alsamixer a ssoonas you try alter volume within it, its going quiet and you can not.do anything