RoPieee/Raspberry Pi 4 - installation issues

Desperately seeking some suggestions please. I’ve spent hours over the last 2 days trying to install RoPieee in my new Pi4, with no joy at all. I’ve been following the guidance from the Beginner’s Guide referred to in several posts here, still no joy.

The main issue seems to be that I’m unable to open the web user interface, but I also am not able to locate a url for the Pi in my macbook’s Terminal nor by running a port scan on Fing, and it is also not visible on Roon. The flashing light on the Flirc seems to indicate that the installation has been completed.

I’ve reflashed the RoPieee image many times and started the entire process again, but nothing seems to work. I’m hard-wired into a working WiFi router.

This would appear to be about a 30 minute process for most people, does anyone have any thoughts or suggestions as to what the issue might be?

Hi Derek
Not sure how technical you are so a few pointers

I am assuming that the Pi is plugged in via Ethernet.

Look at your router and see what has recently been given a DHCP address.
That should tell you what IP address to connect to

Give that a try first
Good luck

Mike

Mike thanks for your help. I’m not all that technical, my greatest achievement of this sort is building a NUC and installing ROCK last weekend.

Ive been to my router via internet access and see no raspberry. There is something titled ‘Unknown Device’ and when I try that IP address the page doesn’t load. It looks much like when i try to open ropieee.local.

Yes, ethernet cable into my router.

Can you attach a monitor?

Derek well done on building the NUC, it’s a good learning stage.
I think I read that you are on a Mac.
From the terminal try and use the ping command to see if the latest device is active, replace the.27 with the address given.

Ping 192.168.1.27

Beyond that are the Ethernet lights on both the switch port and Pi

You can also try replacing the Ethernet cable between the Pi and the switch.

Mike

Nick I thought Ropieee disabled HDMI out on boot.
Not that I have tried it recently

No, you get messages about your network connection.

1 Like

Ok good news :+1:t2:

Mike - you may be onto something here. There is no light on the Ethernet input on the Pi, but my router has no light. The cable i’m using seems to work in another application, but I’ve just switched it out for another and lo and behold a light came on, and i can now access ropieee.local. I’m going to carry on for a bit and will update this post with results.

thank you all for taking the time.

d

1 Like

Derek great news, we all learn from each other in these forums.
Have fun getting this up and running, and you too might be helping people out in a few month’s time :+1:t2:

Mike

2 Likes

Well that’s done the trick! A dodgy cable or connector has made this job a bear. But my little Pi4 is now running Ropiee on my wireless network.

Thank you all for your comments.

D

4 Likes

Derek
In that case the only thing left to say is enjoy the music

2 Likes

Glad you got it to work and great to see community help on the forum! I also have a RP4 running RoPieee in a Flirc case with USB wifi dongle and works great for USB audio output to my DAC.

Enjoy the music!

2 Likes

Nice work Mike!

2 Likes

Toss that cable…it’s not worth keeping to have some other issue with it down the track. :sunglasses:

1 Like

Yep, it’s already binned. :+1:

1 Like

I’ve had the same issue. I’ve done many Ropieee installations on Pi 3’s without issues. I have tried the same on a number of Pi 4’s with no luck at all. It starts up and stalls on the small multi-color rectangle that first appears when you start a Pi.