Ropieee + RoonBridge - recognized in "about" but not displayed in the "audio" tab

I had a similar issue.

Could something be added to the Ropieee.local page - Information tab perhaps - to show whether Roonbridge has been properly installed - ideally with option to reinstall Roonbridge without having to do complete reinstall of Ropieee.

Yeah, the groundwork is already done for this.

Looks like I have a different issue. I have 2 RPis running Ropieee - one shows up in Roon and one doesn’t. Reinstalled Ropieee - made sure internet connected - can connect using web page but not available in Roon. It does show up in the ‘About’ section of Roon but not in the ‘Networked’ section of audio settings.

So, (@support @spockfish) looks like Roonbridge is installed on both but only one is available for playback in Roon. Any suggestions?

Are you using a USB DAC on one of those? Keep in mind that in that case the DAC should be turned on.

One uses HiFiBerry Digi the other uses IQAudio Digi Amp. The one working is the HiFi Berry one.

Both were working fine until a couple of days ago.

Hi @DuckSoup ----- Thank you for the report and sharing this observation you have made with us, both are very appreciated!

Moving forward, to help aide in our evaluation of this behavior you are reporting may I very kindly ask you for the following information:

  • A brief but accurate description of your current setup. I want to have a better idea as to what you Roon setup “looks” like.

  • You mentioned that things were working “a couple days ago”, any changes to your configuration at all during that time? Just wondering if something could be having influence on this behavior.

  • While it may seem elementary have you tried rebooting all of your devices? This would not only include your core machine and endpoints, but also any relevant networking hardware as well.



What also can be the issue is that although RoonBridge is running (hence is shows up in Roon), the audio device is not.

Can you send me feedback of the unit that doesn’t work?


Hi @eric @spockfish

Setup is Mac Mini running Roon Server, Macbook Pro to do setup of endpoints, 2 Raspberry Pis - one with HiFiBerry Digi+ and one with IQAudio Amp, also 4 Bluesound speakers. Mac Mini, macbook Pro and RPi/IQAdio are ethernet cabled to same switch, Rpi/HiFi Berry is on network over mains (Devolvo Plugs). Bluesound kit is wifi.

I tried reinstalling Ropieee on the one that wasn’t working (IQAudio) - same as before. Then I cloned the image from the HiFiBerry Rpi, put it on the IQUAdio one and (using Ropieee web page) set DAC to IQAudio. Roon still couldn’t see it.

I wondered if it might be hardware so I put DietPi on the IQAudio Rpi and it works fine. It restored the queue in Roon so I could see that the last time I played anything was 23rd Jan. I don’t remember doing any updates - although Ropieee and Roon are set to update automatically.

I’ve got a busy weekend but, next week, will put Ropieee back on the IQAudio RpI and run some diagnostics.



Hi @DuckSoup,

Would love to see the feedback. If you got some time then please hit the feedback button on the ‘advanced’ tab so I can have a look as well.



I had a same issue.

My setup :

  1. Roon Core : Synology NAS DS716+ (8GB RAM, External 256 SSD)
  2. Roon Control : iMAC & Android Phone
  3. Output :
    Ropieee1 : USB-DAC (Recognized)
    Ropieee2 : Emotiva DC-1 (Not-Recognized)

When I connected Emotiva DC-1 into Ropieee1, it was recognized. So, I don’t think the problem is related with the DAC.

Have you reflashed already? This sounds like the RoonBridge installation (which takes place during RoPieee’s installation proces failed).

Hi stockfish,

Thank you for your comment.
I fixed the problem today. It was USB cable problem.
I reflashed it but it was still showed the problem.
So, I switched the USB cable with the other ropieee and now it was connected.

Thank you again and sorry for make noise…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.