RoPieee screen only showing "unknown"

Hi I have used Ropieee with succes, and now just bought the official PI screen. So I installed the software from scratch again, waited while it updated it all, reversed the screen from the webUI and enabled the remote control extension. It plays fine as before, but the screen is only showing “unknown” and I cannot change anything. I can access screen settings in the lower left corner. What am I doing wrong?

Hi @Henry_Larsen,

It sounds like you forgot to configure the zone in the web interface you want to control. This is essential yo get stuff working.

So can you check that?

I had the same Problem
Go to the RoPieee web interface
I used the Hostname (in my case ropieeeDisplay) for Roon Control Zone you can find in the Display tab.
Then I canged in Roon the “Roon Control Zone” to the “Hostname” of the Display.
Then you also have to look in Roon for the Extension.

Your Problem

RoPieee web interface Geral tab

RoPieee web interface Display tab

In Roon the Settings

I changed the Zone Name to the Hostname as well

The problem is fixed

1 Like

thank you to both of you - that was the problem and now it works


Don’t forget to click on the cover art to see the new interface.

1 Like

Help! I’ve got a similar issue. I’ve followed the instructions posted above, when I goto the display tab and type in the Roon control zone, it appears to take the setting, but on navigating back to the site and clicking the display tab, it reverts to ‘Unknown’ each time.

Any ideas?

Feedback was sent : 498303ed724791d9



Hi @Matthew_Lomax,

Looking at the logs, I’m wondering if you’ve rebooted after zetting the zone from Unknown to LivingRoom. The logs suggest that you didn’t reboot after changing the settings…

Can you retry and reboot?

Just reapplied name, and rebooted and… bingo!

Now up and running :smile:


1 Like

I too am having this problem after changing my roon core to Roon Rock.

I can access the Ropieee web page and all the settings look correct.

When I look at my roon page, I can see that the extension is enabled. However, when I look at the audio setup, I don’t see my ropiee display.

What could be causing the problem?

I’m still not sure what you mean.

Do you have a display connected?
What’s behind the RoPieee unit? A USB DAC?

If you are using RoPieee to control a Touchscreen, then the RoPieee Remote Control shows up in the Roon Extensions page. If you are using RoPieee to support a Roon endpoint connected via USB or a HAT device, then that will show up in the Audio Settings page.

They are different functions and show up on the appropriate pages in Roon Settings… A display is not an audio endpoint.


I have a display connected, with an allo boss dac.

Looking at the web page, please note my general and display settings.

The extensions for each of my Ropieee setups are displayed.

roon extensions ropieee

However, when I look at the audio settings in Roon, my allo boss dac which has this display, is not shown.

Does this make sense?

ok clear. So the unit is not showing up in the audio section.

Can you go to the ‘advanced’ tab of the web page and hit the ‘feedback’ button?
Then I can have a look to see what’s going on. It sounds like the Allo Boss isn’t detected properly, but let’s have a look.

Regards Harry

Hi Harry,

I have this identifier from the feedback button:


Please take a look and let me know how to proceed.

I am also having the “unknown” issue with my other boss dac. This actually shows up in the Roon audio settings, but I am still getting the unknown error. This is the number from the feedback page: 1b45f0b8b48abcfe

This is under the ropieeeDisplayLR



Hi Harry,

Have you had a chance to look into the issue I am having?

Thanks Bruce

Reinstalled Ropieee in each of my two setups and everything is now working well.

No I didn’t had the chance to look at it, but fortunately you fixed things yourself :wink:


I am getting the “unknown” screen when there is a power cycle on the RoPieee. Here is the sequence:
1- Power “off” the RoPiee Rpi3 using onboard USB audio to DAC with Ethernet connected.( I am waiting for my Allo Digione card to arrive).
2- My Mac Roon Player disconnects from RoPieee and prompts to select an Audio Source.
3- Turn power “on” the RoPiee.
4- The Mac Roon Player automagically reconnects to the RoPieee audio endpoint and shows that it is connected.
5- Unfortunately, the RoPieee Screen (Rpi3) still displays “Unknown”.
6- Press “Play” on the Mac Roon Player.
7- The RoPiee now displays correctly and the music plays.

So its no big deal but I have to keep the Ropieee powered all the time otherwise I would get an ugly “Unknown” display in my living room. Also happens with any power outage.

Thanks in advance, great app.