Ropieee setup stuck on "Time sync failed, trying over HTTPS"

For some reason it’s been stuck on this state for the last 30 minutes or so.

Have you tried rebooting your RPi?

Ok, it did proceed to stage 3, the last output messages on screen were
“Trying over HTTPS”
“Check for updates”

The Rpi rebooted after a few minutes and I got a blank screen. I can’t access via its web interface http://ropieee.local/

I’m not sure if the installation/setup suceeded or not.

Can you find the RPi’s IP address? You should be able access the interface by entering the IP address in your browser.

I can’t find its IP (used fing). I restarted it a few times and it kept going back to stage 3. The same pattern emerged, same messages (Trying over HTTPS, TIME SYNCED!..etc), screen went blank again.

Once again I restarted the Rpi and it went back to stage 3.

The problem just keeps repeating itself.

I have 3 different Rpis (one Rpi 3 and the other two are Rpi 4s), all have the same problem. I had no problem installing Volumio or Moode on either on them.

It might be worth re-flashing the Ropieee image on to your micro SD card. Other than that, @spockfish might have some suggestions.

Tried flashing on 3 different SD cards, no joy on any of them. Had no problem installing other RPi OS on them.

Im not sure what you mean with stuck. Stage 3 means your operational and yes, RoPieee disables the screen at that point.

Ok, assuming it’s operational, I’m still unable to access it via the web interface. Anything I can try to troubleshoot?

How are you trying? Are you following the most excellent instructions?
Have you established the IP address? You can find it by looking in your router, or using fing, as detailed in the afore mentioned instructions: Configuration, step 1.

Yes, I followed everything to the letter from that resource (it was the first I referred to). I used Fing to look for its IP on my network. I can see every single device on my network (including a separate RPi running Moode) except for the RPi I flashed with Ropieee.