RoPieee showing "Connection Failure" quite frequently


I just added the 7" display and reinstalled RoPieee to enable it. Sound works fine and in general the Screen UI is super, but ever so often it shows a “Connection Failure” screen before it resumes normal function. This happens multiple times per minute. Looking at it from Roon extension config page it shows the extension goes from status running to disappearing altogether and then returning to running when RoPieee goes back to normal. The music plays uninterrupted while this happens.

Only wired Ethernet for the involved parts (Library, Core, RoPieee) and since the music is playing I assume I got the zone name right in the RoPieee config, right?

Only thing I can think of is that the under-voltage icon was popping up every now and then during boot. (Power supply is specified as 5V 3,1A so I thought it would be enough to power a Pi 3B plus the 7" touch screen…)

I sent feedback e671c8a2df253602 for your troubleshooting.

Thanks for your advice

Wanted to check if the Ethernet port went down so logged in with ssh and while the screen was displaying the connection failure I submitted an ls command to see if I had to wait for the response or not but seems Ethernet was still up while it happens (reservations for it not lasting very long but seems to be responding). Also tried rebooting the Core, but it didn’t help.

Weird. What I see in the log is that the extension regularly crashes because of a timeout in the connection with your core. And that happens continuously: so Roon core detected, connection setup, timeout when connecting, crash… and repeat.

You have one Roon core?

Yes, I have one Roon subscription so Roon itself would not allow more than one active core as far as I understand. There are some (5?) computers with the full set of Roon functionality on them, but only the ROCK at is active as a core.
I have various network devices connected through three switches connecting through another switch with some devices connected only through the main switch, but it doesn’t seem to be a connectivity issue. Both RoPieee and Core are connected directly to the main switch.

Today I have moved the RoPieee to another DAC (and another switch port). Saw the same problem there, but after I moved it back it has become more stable (but not fully - when I check, Roon’s extensions page shows RoPieee running eight minutes right now, so I think there’s still occasional dropouts.) No idea what could have caused the improvement since everything is still the same as when there were more frequent problems…

What is your core running on hardware wise?

Core is Roon ROCK on an Intel NUC D54250WYK. Three different DACs; TAD D-1000 driven by RoPieee, Exasound e38 driven by a headless tiny computer running W10 and Pioneer U-05 waiting to be driven by my other NUC D54250WYK with W10. Library is on a Readynas. I’m only listening to my local library.

1 Like

Not exactly far above the minimum spec for roon. Ymmv. Can you try the core on a faster system to see if that helps?

Thanks for bringing up ideas.

Moved the core to my HTPC (a fanless mini Intel i7 7th generation with w10 pro, 16GB DDR4 and 256GB SSD.) Still is shaky so I suspect some disturbance in the network. I’m gonna make a complete network diagram so it gets more comprehensive how I’ve set it up. It’s not trivial so might be the cause of it…
Obviously I’m not running Kodi or doing anything else on the HTPC when listening to music.

Here’s my network “diagram”. Each new indentation level means one more piece of networking equipment to traverse. I’ve added a # sign in front of the equipment used by this use case. All IP address allocations by dhcp and mostly reserved addresses in the broadband router.

Internet (100Mbit Fiber)
#   Broadband router
        (IP Telephony, converted to analogue RJ-11 outlet)
        Intel NUC, Roon bridge for headphone rig, bedroom
#       RoPieee, living room stereo rig.
#       Top level switch (not counting the broadband router)
            Old w10 Laptop. Normally not very active.
            Cascaded switch, bedroom
                IP-TV box 1
                Raspberry Pi with LibreElec
#           Cascaded switch, living room
                IP-TV box 2
#               HTPC (New Roon Core computer)
                Aria Piccolo - used for CD ripping exclusively.
                Pioneer Receiver (does not really need to have Ethernet connected...)
#           Cascaded switch, office
#               NAS, music library
                NAS, movie library
                NAS, other content
                Stationary computer, mostly turned off.
                Philips Hue hub
            2 * iPad Pro
#           2 * iPad mini (1 is the main Roon remote)
#           2 * Macbook pro (Sometimes use one of these for Roon navigation)
#           2 * Logitech Harmony Hub (the one in the living room...)
            withings scale
            Nokia sleep tracker
            Work laptop, during the pandemic social distancing

I have exactly the same problem described here. (I first posted about is a couple weeks ago: Ropieee Remote connection issues)
My core runs on a MacMini Intel Core i5 (2,3 GHz) with 120GB SSD + 8GB Ram. This machine is dedicated to Roon Core. The music catalogue sits on a USB attached SSD drive. The MacMini is connected to the router by Ethernet. WiFi is turned off on it.

The RaspTouch is connected to the network via WiFi.

When monitoring the Discovered Extensions screen on the Roon Core - you see the Ropieee Remote Control disappearing randomly and then coming back.

Connecting RaspTouch via Ethernet does not seem to make a difference.

The Roon Android app I use on a recent tablet or on a recent Android phone to browse & select music, also looses connection to the Roon Core very often. When it is awakened from the background it either needs to find and connect to the core again or the app relaunches.

Maybe this is another symptom of Roon Core connectivity problems.

What is your network like…is it apple…if so that’s perhaps a yellow flag too

No. My network is a FRITZ!Box 7590 ( Roon Core connected to a Netgear GS305 Gigabit switch which is connected to the router. I use quality ethernet cable from Audioquest. My streamer (Pro-Ject Streambox S2 Ultra) is also connected to the Netgear. All other devices which run Roon to control music playback (MacBook - Huawei Mediapad - Google Pixel 2) are connected via WiFi.

My library is a mix or ripped CDs and Tidal tracks.
Sometimes the Streambox will reboot itself. Usually this is forewarned by playback problems such as “Roon cannot load this track”. It does not seem to make a difference if it is a Tidal track or one in the local library.
This happens very rarely. When it does, then I usually also close and restart the Roon Core and reboot the Mac Mini. After that I am good for 3-4 weeks (60-80 hours of playback).

@RedDog @Daniel_Enochsson It might be worth both of you opening #support threads with details provided there and the roon logs can be looked at.

Good idea. I am game to do this.
Can you tell me how to retrieve Roon logs?

Can you send me feedback? Keep in mind that this is not related to Roon functionality itself, but to RoPieee’s extension.

You can find the feedback button the ‘advanced’ tab.


What would you like to receive? Roon logs?

No feedback. As mentioned, you can find that on the advanced tab of the web interface.
There’s a button labelled ‘send feedback’.

Edit: Sorry for the fake news in the paragraph below. I was convinced that my switches were Netgear, but they are D-Link DGS 1008 D.
Me and Marc have one factor in common. We’re both using Netgear GS gigabit switches. My ethernet cables are nothing fancy though, but at least made for gigabit speed.

You already have feedback data from me, @spockfish. Do you need one more?

My next step is to temporarily remove all non-essential network devices to see if that changes things. Can’t keep it like that for very long, though… Anything specific I can do to assist troubleshooting while I run with reduced complexity?
I should be able to get it down to the following pieces of equipment:

  • Internet (100Mbit Fiber)
  • Broadband router
  • RoPieee, living room stereo rig.
  • HTPC (Roon Core computer)
  • music library NAS

I am also having those connection failures often.
My Roopie is only used as display so it is not so serious issue, just get those black srceens with notification.
feedback : 57228cf1aedc8220