RoPieee showing "Connection Failure" quite frequently

Can you send me feedback? Keep in mind that this is not related to Roon functionality itself, but to RoPieee’s extension.

You can find the feedback button the ‘advanced’ tab.

Thanks

What would you like to receive? Roon logs?

No feedback. As mentioned, you can find that on the advanced tab of the web interface.
There’s a button labelled ‘send feedback’.

Edit: Sorry for the fake news in the paragraph below. I was convinced that my switches were Netgear, but they are D-Link DGS 1008 D.
Me and Marc have one factor in common. We’re both using Netgear GS gigabit switches. My ethernet cables are nothing fancy though, but at least made for gigabit speed.

You already have feedback data from me, @spockfish. Do you need one more?

My next step is to temporarily remove all non-essential network devices to see if that changes things. Can’t keep it like that for very long, though… Anything specific I can do to assist troubleshooting while I run with reduced complexity?
I should be able to get it down to the following pieces of equipment:

  • Internet (100Mbit Fiber)
  • Broadband router
  • RoPieee, living room stereo rig.
  • HTPC (Roon Core computer)
  • music library NAS

I am also having those connection failures often.
My Roopie is only used as display so it is not so serious issue, just get those black srceens with notification.
feedback : 57228cf1aedc8220

I have rearranged my network cabling so now Roon Core and RoPieee are directly connected to the Broadband router and music lib on the NAS is connected via one switch only to the router.
This hasn’t helped fully, but generally it’s hours between losing connection now when it was minutes before. This happened already in post 5 of the thread though, long before my rearranged cabling and I don’t understand what caused it since nothing really was changed after I moved RoPieee back…

The usual stuff: timeouts on the server.
And you’re on wifi :wink:

Anyways, not much I can do about it right now.
I’ll ad a note to my list to see if I can make it a little bit more resilient to these timeouts.

Hmm… I might be onto something.

2 Likes

“you’re on wifi” - I’m assuming that was for @Pertti_S since I have wired only (except Roon remote clients.) Both Core and RoPieee are connected to LAN outputs on the broadband router.

It´s same with wired connection, first thing I tested to use wired connection and after I find out that same happens with that I swapped back to wireless. Definetely problem is in side of Raspberry not the network.

I finally got around to doing this. I had no network errors (that I noticed) up until last night.
Here is the identifyer: c796646f6eae46a7

So … does this mean it hasn’t occured anymore or does this mean you saw it last night and sent the feedback after that?

I’ve pushed a minor update to the beta channel that might make the extension a little bit more robust: if you see it happening again you could switch to the beta channel to check it out.

Thanks

I had not seen any connection issues until the evening before I sent the report. But I had much lower listening activity.
There was an update pending this morning and I installed it.
I will try the beta if I see more connection interruptions.
Thanks.

1 Like

The connection failures are appearing less frequently after I rearranged cabling so both Roon and RoPieee are connected directly to the broadband router from my internet provider. It seems to lose connection momentarily when coming to the end of playlists playing to the zone that it’s endpoint for, but other than that it is quite stable now. Still I think that it should be possible to add some switches in between without losing stability - especially considering that it’s all wired gigabit ethernet.

Now it’s not happening often enough to be used as a testbed but if you like @spockfish I can load the beta and check if that gets rid of the loss of connection after a playlist comes to an end.

Yes that would be interesting.

So you’re saying that it is always happening in the case of an ‘end of playlist’ event?

I was only observing the status twice before and then it changed from Running (nnn) to Running without minute indication and when it started showing Running(nnn) again the minutes had started from 0. Then I tried it again and didn’t get the same result so it’s happened two out of three times here. I’m currently loading the beta (version 2.5.4.5) to see if that makes any difference, but it may have to wait until after the weekend since I’m quite busy the next few days.

I played one album with beta software and Running (nnn) didn’t reset at end-of-playlist - i.e. connection remained. But since there’s so few tries I’m not sure what conclusions one can draw from it. I’ll test some more in a few days.

1 Like

I have been running this beta 2.546 and problem persist still

feedback : 9d0ce560f30ce53c

Noticed that at roon server discovered extensions dissappears most of the times when you get the error at roopie display.
Screenshot 2020-07-05 at 9.54.57
Screenshot 2020-07-05 at 9.55.26

Continuously time outs reported when connecting to Roon core.
Nothing much I can do about it, but I would definitely suggest you investigate your infrastructure as the time-outs are rather frequent.

There is nothing to that I can do with network, if I run both connected ( Roon core and roopie) directly to my Cisco Catalyst 9300 switch I get also those errors. Maybe problem is at Raspberry side (power supply etc…?) I tested also Dietpi as a display, that works without problems, but it´s not as nice looking as roopie.