RoPieee to Topping USB DAC - sleep mode?

If anyone is using an RPi with Ropieee as a Roon endpoint connected to a Topping DAC via USB, then I’d be interested in the following:

When you’re not playing music, does the display of your Topping DAC turn off? In other words, does the DAC go into sleep mode? My Topping D90 is in my bedroom and this would be quite important to me as the display is quite bright.

The display of my Topping D50s is off during playback and when switched off. In other words when switching on or off or change settings the display is on but goes off after several seconds.
There is also a auto switch on/off setting in RoPieee.

1 Like

In Ropieee under the ‘Advanced’ tab there is a setting ‘USB Auto Suspend’. With that ‘enabled’ my Topping D10s will switch off after Ropieee stops playing music through the USB port of the D10s.
Not sure if my D10s is comparable to a D90 as the D10s is powered through USB from the Raspberry Pi with Ropieee.

1 Like

My D70 switches goes into hibernate after a few minutes with nothing playing and switches on automatically when I play to it.

1 Like

Thanks all, it does look like it will work as I expect it to. I’ll know in a few days time when I’ve got my Roon system up and running.

I’m testing this out with my Topping D50 which is one of my endpoints and I think it is working now. My next endpoint will be my D90 and that’s the important.

As for my D50, I’m powering it via USB from the RPi. It’s a nice compact endpoint!

2 Likes

My Topping D90 is behaving perfectly with RoPieee - it goes into sleep mode when no music is playing.

However, I built a new RPi with RoPieee to connect to my Topping D50 and it stays on when no music is playing. It is connected via USB. When I stop playing music to it via Roon, it does go into sleep mode after a few seconds. However, it then starts up again almost immediately and stays on. This suggests that the USB interface is ‘live’ in some way and the Topping D50 thinks there is a digital audio signal being sent.

USB Auto Suspend is enabled in RoPieee. RoPieee version is 4.002 Stable.

Any ideas on how to troubleshoot this? It’s not a big deal as I can manually switch the Topping D50 DAC off when I’m not using it, but it would be nice to have a fully automatic system.

USB autosuspend requires the device to ‘play nice’. That’s why this is optional, as most devices do not support this feature. My guess: this DAC is one of those.

I’ve done a factory reset on the Topping D50 DAC. I’ve also disabled and enabled USB auto-suspend in RoPieee (along with a couple of reboots). It does seem to be behaving itself now!

1 Like