RoPieee + Topping D90 USB DAC

Hi, I have a question for owners of this DAC regarding volume control. Does the USB connection allow you to control the volume from within the Roon app (is device volume enabled in Roon settings)?

I’m also interested in the answer to this question…and/or how volume control works with any of the other Topping models using a similar RoPiee set-up

Can confirm, Ropieee with a Topping D90 supports Device Volume (as well as Native DSD)

Volume control from the roon app is functional with both “DSP Volume” or “Device Volume” chosen in the device setup in Roon settings.

The DAC volume itself stays locked at -00.0 though, it appears that all the attenuation is being done by Ropiee. The volume buttons on the D90 (or via remote) are effective but not coordinated with the Roon/Ropiee volume setting. I can have roon at 100% volume but the D90 at a lower volume, or the other way around, or both at lower volumes and the attenuation is additive.

If I change the D90 configuration from Pre-Amp mode to DAC mode (fixed volume) the Roon/Ropieeee volume control is still functional.


Thanks for this useful information.

Ah, thank you. Was hoping it would let Roon control the Topping DAC device volume directly, but not surprised it is controlling just the Ropieee endpoint.

Hi, received the Topping D90 MQA yesterday and still trying to figure out how to change from Pre to DAC only, somehow can’t do that from the remote control. Guess I’m overseeing something obvious, anybody here who knows?

Power it off. Hold down the “SEL” button. With the button held down, power back on.

1 Like

Thanks Nugget, working now.

Was hoping the same but no unfortunatly. Anyhow very happy with this device. Great sound. Now trying to get used to using a remote control versus my mobile for changing volume.

An update related to the D90 MQA. First, as background, I updated the D90 MQA with the latest firmware (V1.23) which required Windows with the Topping USB drivers. The update was successful running via a Parallels virtual machine on MacOS.

(1) D90 MQA volume control via Roon Device Volume works when using MacOS USB direct (Coreaudio). Of course, then the MQA/DSD functionality is via Roon.
(2) D90 MQA volume control via Room Device Volume does not work when Exclusive Mode is enabled. Volume is then fixed. Remote works to control D90 MQA volume under this condition when D90 MQA is in PRE mode.
(3) D90 MQA volume control via Roon Device Volume does not work from RopieeeXL (4Gb Raspberry Pi 4 with touch display). Remote works, however.
(4) Since I also have a D50s, I can confirm that Device Volume does work from RopieeeXL except when playing DSD files for some reason. Device Volume slider is active for DSD but it is ineffective. Remote for D50s continues to work.

All around odd and inconsistent. I have an email into Topping service to inquire about these results. They are away for Dragon Boat holiday, however, so response may take a few days.

1 Like

Update: I received a very nice reply that they were investigating the USB HID/volume behavior with Roon and Linux ALSA for the D90 MQA. They indicated they didn’t have much experience with Roon. They also confirmed that the D50s volume control doesn’t work even using their own USB ASIO drivers on Windows; it remains fixed in this configuration. More to come, I hope!

Thanks for having this raised with Topping. Looking forward to see a resolution somewhere in time.

Love the sound of this DAC.

Hello, has this issue resolved. I am planning to get RopieeXL and D90 MQA (running is DAC mode - preamp disabled). I would like to know if the Volume Control from Roon works?

I can verify myself as I just got the D90 MQA. The Roon Volume control does not work with RopieeXL and Roon. I can choose Fixed or Device volume and the Roon Volume still says Fixed Volume.

DSP Volume seems to work, but then the MQA does not work when I attenuate the volume with the DSP Volume. If I leave it to 100% then the MQA activates.

I think I will return the D90. It sounds great, but the usability with Roon is not that good, when I got used the device volume of my previous DAC.

I doubt it will work if you’ve disabled the D90’s volume control by disabling the preamp. You’d have to have the preamp function enabled, I’d think, in order for the Volume Control from Roon to work.

Hello, Bill. I had the Preamp activated. The Volume on the D90 works with it’s own remote control, but Roon just states that the volume is fixed. So, the issue is the the same as ExUnoPlura wrote about above.

I also tried it with DAC mode, but that obviously did not work either.

1 Like

I think the next step would be to look at the spec for USB Audio, and confirm that Topping is presenting its volume control over the USB pipe as per spec. That would tell use whether the issue is on the Roon side, or rather the Roon Bridge side, or on the Topping side.

To figure this out, it would be helpful to talk to someone who is familiar with the output side of the Roon Bridge.

One thing I noticed is that Topping D90 reports the max and min volumes as zero for Roon via Ropieee. So, if you go to the device settings the Device Limits Min and Max are both zero and you cannot change them.

If I look at my Node 2i Device limits it says Zero for Min and 100 for Max.

Screenshot 2020-10-22 at 7.30.50