Ropieee volume issue

I just installed Ropieee XL on a Pi4 and have a USB DAC connected.
The issue happens with any DAC (I tried two) and it is like this:

  • First, in Roon audio devices I see two: the DAC and the Ropieee which shows as a Shairport device and Roon plays to it via Airplay. I am not sure if this is normal? I was expecting that since Ropieee runs RAAT it would appear as a RAAT device not as an Airplay device to Roon?
  • Second and this is in fact the problem that bothers me is that when I select for playback the Ropieee over Airplay the volume maxes out quite low and at about 80% it is already almost mute, so the range of volume adjustment is very low. The same thing happens when playing Airplay directly from Apple Music or other app, outside of Roon.
  • When selecting the USB DAC everything is normal.

Is there any way to correct this? I couldn’t find anything obvious in Ropieee settings. There is a ‘force volume’ setting but I’m not sure what it does.

Thanks,
Dan

Hi Dan,

The first is normal. Roon also supports Airplay protocol, so if this enabled on a device like the XL the device pops up 2 times in Roon: one for RAAT, the other one for Airplay.

But in general I would say: if you want to use Roon you should always prefer RAAT over Airplay protocol.

I’m not sure I understand you correctly about the volume stuff. Is my assumption correct that you actually use volume control on your DAC instead of having it set to fixed?

Thanks

Hi Harry - thanks for the reply and indeed for the entire project!

I am using the USB DAC from Roon, so that is all working fine.

But my wife refuses to use Roon if you can imagine such an attitude! Because I still love her and want her to enjoy music I wanted the Airplay capability, but when using Airplay I run into the mentioned volume issue. I just mentioned that the same thing happens when using Roon+Airplay because I thought that might be helpful context.

And to your last question, yes, I am using device volume when using Roon to play music through the DAC. Should I change that?

Do you have your DAC connected to an amp with volume?

Yes, the DAC is connected to a pair of active speakers (Adam Audio T5V) However, using their volume controls is not convenient - they have no remote control and the volume knobs are on the back of each speaker. In use I leave each speaker’s volume set and control volume from the iPhone Roon remote.

Ideally I would like to have the same ability to control volume in Airplay as I do with the DAC in Roon, so I was hoping that there’s some setting that would allow that.

@DanMtsn do you have the “Volume Control” setting enabled?

Yes it is enabled.

I use DSP for volume control.

In answer to Jim F

For the device in question I don’t even have that option

@DanMtsn I’m not sure if your response was to me, but if so, my screenshot was from the RopieeeXL config page accessed via your web browser, and has nothing to do with Roon’s own config screens (which I assume you posted above - I don’t actually use Roon, just RopieeeXL).

@DanMtsn also, just confirming you’ve actually turned up the device volume on the device (iPhone, laptop, etc) you’re streaming from over AirPlay?

No, that was the answer for Jim F

I answered your question positively. My Airplay config looks exactly the same as yours.

@Mark_Henderson
@Jim_F

Should I understand that you didn’t experience the volume issue I described? Which would mean there’s some problem in my setup?

I have not experienced any volume issues connecting over AirPlay from iOS/Tidal to RopieeeXL. I’m able to change the volume on iOS.

1 Like

I have had no problem. I tried Airplay once with my iPhone and Apple Music. I used the iPhone to control volume. I have a Dragonfly Cobalt plugged into the USB port. When using Roon, I control volume with DSP. I have had no problems.

1 Like

I understand now what’s going on.
When you have a raspberry pi with Ropieee you will have two zones: one is the USB attached DAC and the other is the software running on the Pi and makes it a Roon bridge. However, regardless of which zone you choose, the signal is still processed by the USB DAC. If you choose to play music via Airplay, the external DAC is still involved in processing, which makes perfect sense as otherwise the DAC would need the capability to be bypassed.
But because of that it seems that the volume range available for volume control in Airplay is limited by the DAC volume, which is set in the DAC zone.

You can actually start playback on Airplay and then start Roon, go to the DAC zone and adjust the volume there.

@spockfish is that correct?

Now, as far as I can tell this does not seem to bother most users since there is only one other thread raising a similar issue. Which makes me wonder how come? Either Airplay on Ropieee XL is not widely used, or people are adjusting the DAC zone every time they want to use it? Or is there a way around it? I tried using ‘Forced volume’ to 100 but that isn’t it - it does nothing to solve this.
Or maybe this doesn’t happen with HAT’s?

What you describe is correct.

the ‘Forced Volume’ setting has nothing to do with this, it’s related to initial startup only. I guess that most people (I do) run stuff with ‘Fixed Volume’. And in that case there is no problem.

The challenge is that basically the volume needs to be reset when you start a session. Roon does that by itself when you hit play, but not all services do that.

However, reading through some documentation and code, shairport-sync (the software we use for airplay) should do that as well: it remembers the last hardware volume level and resets this whenever you connect via airplay.

Next weekend I’ll do some tests with a device that uses volume control (right now I don’t have that setup).

Thanks

So @DanMtsn,

Just to be sure: volume control for Airplay is enabled in the web interface?

@spockfish
Harry
Volume control is enabled, screenshot below.
I tried setting both zones to fixed volume and they are both now limited to the max volume the DAC zone had before changing the setting, same with Airplay. If the DAC is set to let’s say 24, then everything is limited to 24 etc. So if I understand what you’re saying I should keep fixed volume, control volume outside of Roon/Ropieee via amp controls and then I would have full range when using Airplay outside of Roon, right?

If that is the normal behavior it doesn’t work for me for the reasons explained above (amp control of volume really very inconvenient). I either give up on Airplay or find another Roon bridge distribution for Pi that supports Airplay.

Do you think full range of volume control can be allowed for Airplay via a software change? I suppose that would require some work and I fully understand that doing it for just one user doesn’t make sense.

Thanks,
Dan

I want to understand you completely:

  • Let’s see you start playing via Roon. You set the volume to 52 (just a random number)
  • You stop playing Roon and switch to Airplay
  • Now in Airplay the volume is controllable, but the maximum volume is 52.

Is this the case?