RoPieee with CXA80 usb?

Hi community,
i have a CXA80 (
can i just direct connect the RoPieee to the USB from the CXA80 ?

with kind regards



(I’m debating whether my reply will have any merit, as I have a CXA80 in a separate system, too, but I’ve not tried my RaspPi/RoPieee device with it yet.)

Maybe I’ll give it a go today to test.

The hopefully helpful addition to the thread I will provide is that I DID try it in my Parasound HINT6’s USB input and the volume is super low with the RaspPi (when the RaspPi volume is normal using any other DAC).

So I wonder if there’s something about an integrated’s internal DAC that doesn’t play as well with the RaspPi.

1 Like

oh good to know.

since you have the option to test i would really love you to test it.
i can sponsor you a coffee for the time <3

haha, for a coffee ok.

Ok, yep, just tested. Works just fine! :+1: :partying_face:

Volume normal.

(makes me a little crabby it doesn’t work as well with the parasound, but maybe I’ll start a separate thread for that!)

1 Like

Are you getting full 24/192 with USB ?

There was an issue with CA USB and Linux, I have a CXN v1 which didn’t play nice with RPi and a Roipeee due to the Linux

Eventually turned out to br CA class 2 USB implementation, I had to drop back to class 1 ie 24/96 , class 2, 24/192 just didn’t play

Long story …I hope CA have fixed it

I have to be honest, I didn’t check the sample rate, but audio played, sounded good and at normal volume.

Yep, there is the setting on the CXA80 to change from USB1 to USB2 (in manual, I reckon), and I know mine had been set at USB2 (unless it reverted back for some reason).

EDIT: As i think about this, I’m pretty sure it was getting 192k. I’m using RoPieee with HQPlayer and that was set to upsample to 192k. (If that answers your question!)