Ropieee with Hifi Berry Amp

Hi @spockfish , I just resurrected a p3b+ HifiBerry Amp board and reflashed the latest version as old pi died. For some reason its not outputting as loud as it used to through the same speakers I have to go way above 20 to here it all and this is now in a much smaller room so would expect it to be louder not lower.

Also Roon didnt automatically recognise the device as a Hifiberry Amp when added as a zone I had to manually choose it. That may be normal it’s so long since I set this up I can’t remember.

Is it possible something’s wrong with the board or has the driver changed I am having to crank way past 50 and I am in near field position for listening.

Sent feedabck


1 Like

Another thing it keeps resetting to 100% on full reboot. Setting Roon Volume limits does nothing.

Just upgraded to XL and get no sound from Librespot. Tried using software and hardware no joy. I can hear a little click then silence

Another reboot and it’s working for Librespot via software volume which means I have to set via Roon the loudest level then set Spotify level to be lower. Does it not support hardware Volume?

The HAT supports hardware mixer, but you need to configure that for services like Librespot.

Where would I configure that, I set it to hardware in the GUI but get no sound via Librespot at all. Works fine with software though.

Are you sure it is not set to 0?
Have you tried setting it to hardware and turn the volume up in the Spotify gui?

Yes I did that. Nothing it connects and shows its playing but get no sound at all.

@spockfish this also the same for Airplay setting Ropieee to hardware volume results in no sound at all. I can see on my other Ropieee which acts as a remote with touchscreen Roons volume being set to 0. I change in the Spotify or Mac airplaying and volume goes to 100 but no sound.

And what happens with Roon?

Roon works fine but if I change any setting it resets the audio to 0 or set it to 100%. Also noticing it’s resampling hires to 48khz where the hifi berry stuff all support 192/24.

I added this card to an existing build is that the problem? As it gave me an option to select it …

No that should work. Are you sure it is properly connected?

As far as I know. Will double check when I get time as it’s inside a speaker so not easy to check.