Ropieee with Pi4 not seen by Roon - Ropieee broken?

I have now tried two different Pi4 2gb devices and two different sd card images of Ropiee with the latest version (3.020) and the Ropieee device is not seen Roon. I can go to the pi using the web interface and see it listed as a device on my router admin page. I have another Ropieee Pi3 with amp hat and a linux roon bridge pi on my system and these are seen without problem. I know that others have reported this issue but I could not really find any real resolution to this in the posts. Another thing that is rather strange is that is takes ropieee a long time to initialize on the pi4 - up to 20 minutes? Is that normal? Also my DAC is SMSL M8A which works without issue on the roon bridge pi. Could there be something related to network setup? Somewhere I can look to see issues? Any help would be appreciated as I have lost patience with Ropieee and will soon move on to linux with roon bridge. Thanks

1 Like

When I updated recently to 3.020, the Pi would not be seen by Roon until I rebooted my Roon core.

Thanks Fernando - Yes I did reboot the roon core.

Wow. That sounds like a friendly way for asking for support.


Screenshot of my RPi4 connected through USB to a Topping D10s. Your Ropieee configured like this and DAC switched on?

Yes my Ropieee is configured just like that. And yes the DAC is turned on. Sorry for my frustrated request for help. I do appreciate the what Ropieee has accomplished but I have just spent a bunch of time and effort trying to make it run so a little frustrated. But I understand it is a public domain product so cannot expect perfection.

This never worked - bailed on Ropieee and installed Roon Bridge on Ubuntu and worked like a charm. Thanks for all the help .

For a public domain product I see perfection

Well done @spockfish

Have you confirmed your network connection, Ropieee needs it to boot and update, a very slow startup would imply something

I know you have tried but a dodgy SD card/image is a good start

If you are not satisfied you can easily build your own endpoint. Just install raspbian, configure network, audio, some web interface, install Roon bridge and you’re done.

Well as it was not working on two different pi’s with two different sd cards so I would say that there are bugs. Plain and simple. And yes installing linux and roon bridge is the alternative. And honestly I spent a fraction of the time installing roon bridge as I spent trying to figure out why ropieee was not working. Not saying ropieee is not a good product just saying it is clearly not bug free.

Ropieee is working bug free for me on three RPi’s including two RPi 4’s. Author of Ropieee is helpful through this community board in resolving issues. When he replied in this thread “Wow. That sounds like a friendly way for asking for support” you could / should have asked him for support :wink:

yes I have a pi3 that ropieee works on as well. Just pointing out to others who might be using it and having problems that it does not appear to be problem free. In fact others have had this issue on another thread and I did not see any clear resolution to it. Maybe through this thread someone else who is having the same issue will not spend so much time trying to fix it and just move on to roon bridge. And I did not know he was the author of ropieee lol.

I have plenty and all working no issues …

It says so next to his name :sunglasses:

  • Check SSH access unter Advanced
  • ssh root@your pi, pw ropieee
  • aplay -l

You should get something like

[root@pi4 ~]# aplay -l 
**** List of PLAYBACK Hardware Devices ****
card 0: v1 [AudioQuest DragonFly Cobalt v1.], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Check error messages with dmesg |grep -i usb

I have two Pi4 devices in my setup and both work well with Ropieee, USB output, and a couple of different HAT boards. I didn’t time the Ropieee installation process but I recall it did take a bit of time.

Wondering if you’ve given your devices different names. Not sure if naming has any impact and if having two devices with the same name could cause a problem but that’s all I got for you.

My experience with Ropieee is that the product is very well supported especially for a product that is supported through donations.

Hello, I’m new, but have been using roon for almost a year. I’m having almost the same problems as the original poster. I’m trying to set up my first Ropieee on a raspberry pi 4b 4gb connected usb to a schiit modi 2 uber dac. I hope to get it connected to output on both a modi 2 uber dac and a modi multibit dac at the same time.

I have the installation completed and wifi connection configured. I can access the ropieee.local config page and make changes, but I can’t seem to get Roon to see it as a network device.

Help would be greatly appreciated. Is there anything I can try? Thanks!

I suggest you get this working first on LAN connection. Streaming to 2 devices with Wifi will be problematic at best.

I would also suggest you send Harry a feedback.

Thanks for the quick reply! I will keep it simple until I get it working. Wired net and one dac.

What’s the best way to send Harry the feedback?

in the lower part of the Advanced Tab of the GUI