RoPieee without HAT Issues

Hi - installed RoPieee on Raspberry Pi 3 without a HAT. However, I said it had a HAT (Pi DAC 12S) by mistake. RoPieee was found by roon and installed. Now when I correctly say no HAT configured it is no longer found by roon. Even when I try another HAT it is not found. Roon only finds it if I say Pi DAC again. How do I get roon to forget this and start again, as I can’t get any audio out of 3.5mm connection?

The built in RPi 3.5mm output is pretty crappy. Suggest you use either a hat or a usb dac connected, even something as simple as a dragonfly dac would be a higher step up from the pi output.

The issue is that Roon does not see Ropieee, unless I configure to say I have the Pi DAC - even though there is none. So my question was more about how to get Ropieee visible and useable. Thanks.

RoPieee does not act as an audio endpoint itself without:

  1. a HAT based DAC

or

  1. an USB DAC

In the latter case it’s important to realize that the DAC should be turned on to be able for Roon to pick it up.

Thanks,

I don’t know that ropieee enables the 3.5mm audio. @spockfish Harry could answer that. Failing that you could use dietpi.

Roon won’t see ropieee or dietpi unless it has valid device enabled. I2S is a dac interface option for a specific hardware interface.

Re-image your sd card and start over would be easiest I think

Ropieee has good reasons for not supporting the 3,5 mm analog line out: you don’t want to use it for anything. It’s that bad. Really.

1 Like

Thanks for advice. Decided to go with DietPi as only needed for radio in kitchen. Works fine now.

2 Likes