RoPieee won't show up on network - completely stumped

Hi there - I am successfully using two Raspberry Pi endpoints with RoPieee - one is via a Wifi connection, and the other is Ethernet. I did have a third endpoint that I was running and it was another Wifi connection, however, the signal would drop out rather frequently. So I decided to switch that setup and connect the Pi by ethernet. When I changed the settings and removed the ability to connect to my network by Wifi, and then connected the Pi to my network by ethernet, it would not show up on my network.

I figured I screwed something up so I flashed the RoPieee image once again, and tried again…but no dice. I tried a couple of different SD cards, and I tried an extra Pi that I had, and still nothing. It seems to go through the usual steps - fast blinking for five minutes or so, and then the regular, consistent 2-3 second blinks. So I feel that it is doing everything it is supposed to do, other than showing up on my network.

I’m wondering if anyone else has run into this situation. I’m guessing it is hardware related, but it seems weird to me that I would suddenly have two Pi’s suffering hardware issues, especially when the one was connecting to the network via Wifi no problem until I decided to go screw things up. Any ideas?


When you say they don’t show up on your network, are you saying that when you run a port scan they don’t show up? The install seems to work, so your basic networking is presumably fine. (The LED should be once per second.)

Correct. And yes, it’s about once per second.

Are you able to login to your router and check DHCP leases for the devices?

I can login and see which devices are on the network - but the Pi in question does not show. The other two Pi’s that are working fine do show.

Hmm. I can only think of some crazy scenarios, given that the install was successful. I’d be inclined to shut the Pis down, reboot your router and any switches, and only boot the misbehaving Pi in question using one of the known good Ethernet cables of the other Pis.

Question: have you renamed those other units? Hostname I mean?
Might be confusing your router if you leave the hostnames on ‘ropieee’.

Yes - I have renamed both of them.

ok. did you did a hard reboot (remove the power and put it back on)? And are the leds on the network connector on?

Yes to both.

Maybe temporary move it to the other ethernet since it is ethernet that you are trying to setup. This should tell you if it is the endpoint or the ethernet is your issue.


Yeah, it appears to be some sort of Ethernet issue. When I plugged it directly into my bridge it showed up on the network. Then when I plugged it into the Ethernet port in the room where I want to locate it, it wouldn’t show up again. But the green Ethernet LED on the Pi blinks, which to me suggests it is sending and receiving data, but it still won’t show up. Then when I plug my TV receiver into the same port, it works fine. So I’m really, really baffled. It’s looking at this point I’m going to have to go back to giving the wireless connection a try, as I’m not technically capable enough to troubleshoot why device A is working just fine plugged into the Ethernet port, but Device B is not.

Thanks to everyone for taking the time to try and help - it is much appreciated.

Have you got two network address ranges in operation here? When you plugged your TV into the port, does it show up in the addresses known by the router?


Thanks Geoff - your comment sparked a thought, so I went and revisited my network bridge and swapped some things around, and just like that the ‘missing’ Pi showed up on the network. That’s the good news. The bad news is that while it is now showing up on the network, it is not showing up in Roon. I’ve got the HifiBerry Digi+ PRO HAT and the problem appears to be with that. When I take the HAT off and use my DragonFly, everything works fine. But when I go back to the HifiBerry Digi+ PRO HAT, it refuses to show up in Roon. I’ve seen that this is an issue with some other folks and I’ve tried all of the suggestions from those threads, but no dice. Of course with all of the swapping I’ve done between three Pi’s, etc, there’s a very strong possibility that I’ve done some damage to it. Funny - solve one problem, create another…

Again, thanks to everyone for your help and suggestions.

can you send me feedback wirh the digi pro connected? go to the advanced tab and hit the feedback button. i’ll gave a look

Done! 9d9d8d66876b05fb

Hi Chris,

2 things: your unit failed to install RoonBridge, which is being pulled in during installation. From the logs I can see that during installation it didn’t have internet connection. This means you need to reflash, or I can help you out with running some commands if you’re familiair with SSH (a bit).

The other thing I noticed that I saw a few warnings about under-voltage being detected. That’s normally not good, so you might check your power supply.

1 Like

And with that, all issues have been resolved. Thank you!

It looks like I have an issue with one of my Ethernet connections where I have - historically at least - always had an Internet connection. So I assumed that the Internet was fine and working, when it wasn’t. Now I need to figure out what is going on there!

I’ll use a different power supply as well, to hopefully address the under-voltage issue.