RoPieee won't upgrade to XL

Hi there,

I am running version 2.476 stable, and no matter how many times I try to upgrade to XL, it doesn’t stick.

After I select the XL upgrade option on the advanced tab, the unit updates and when it comes back the banner and options are XL options. I have a red box telling me that I need to reboot for the changes to apply. After rebooting, the unit reverts back to non-XL.

Have sent logs via feedback: 7dfda620fb88af6d

Any help would be very appreciated!

Thanks

I had a similar problem and gave up trying to update from Ropieee to RopieeeXL. In the end I just downloaded RopieeeXL from the website and flashed it to the SD card.

I’ll have to tag on here and resume the topic. Tried to install Ropieee XL but without success (RoPieeeXL upgrade via Advanced Tab). Have already tried several times. Reflashed the card but XL is not installed.
Since there is no XL download available on the website either, I can’t upgrade through it.

Feedback = 94bd571d1b833eaf

Hi,

I gave my infrastructure a kick and now it will update.
That ‘kick’ triggered an update (3.075), but you should be able to upgrade to XL.

Thanks

Thanks! Works perfect now.
Thank you for your (really very fast) support.

1 Like

Problem seems to have appeared again.
My streambox S2 Ultra was failing to update (from 3.075 I think) so I had to reflash the eMMC. Only version available on the site was Ropieee (in the past I could download XL).
Flashed the eMMC and then tried to upgrade to XL within the Advanced tab.
Initially looks like it has successfully upgraded to XL…but…the red ‘reboot’ banner appears and on rebooting…back to standard Ropieee :slightly_frowning_face:
At least it has updated to version 3.084…but I would like to get XL back…please?

PS feedback b0ee3f076cbaab8b

The filing system is corrupt hence the update to XL failed/fails.

Oh :frowning:
Will reflashing be the best way forwards then?

Unfortunately yes. I do find it strange though that this happens shortly after you reflashed it.

Thanks for the rapid response.
Currently updating a fresh install. Fingers crossed!

Seems to be something odd going on. I have tried several times (multiple reflashing) to get Ropieee back up and running. No joy. Can sometimes get the initial flash (3.066) running, but even then - immediately after flashing the eMMC - the update (just Ropieee, not XL) fails ie it looks like it’s done it but rebooting takes me back to 3.066.
Given up for now and gone back to Volumio (free version) which is working.
I’d obviously like to go back to Ropieee(XL), but this is proving impossible at the moment. I’m sure the eMMC is functioning. Surely it must be if I can get Volumio working (not the original Sbox version as this is gone forever).

1 Like

Getting same issue - just won’t update to xl - have reflashed SD card, then when that didn’t work i tried a different SD card - exactly the same problem occurs

Still stuck with Volumio :frowning_face:
Maybe your comment might kick things on a bit. However, does not seem like a simple issue for me as it’s a soldered emc card so I can’t even replace it :joy:. Nevertheless, you tried a new card and had the same issue. Maybe it’s something other than corrupt memory.

The issue is still there, or has reappeared. I’m on stable channel, and some Pis do update, some won’t. The homepage still refers to the possibility of a direct XL download which in fact is no longer being offered.

I suggest a reflash and upgrade to XL from there.

I already did a few weeks ago, but will do again and come back to report any luck.

Now it worked. Thank you!