RoPieee XL and intermittent Airplay connection

I’ve just setup RoPieee XL on a Pi4 and am blown away with the elegance and power of this solution. Thank you, Harry!

My primary use-case is streaming Tidal HiFi from an iPad and iPhone via AirPlay to RoPieee XL and then via USB to my DAC.

The RoPieee XL shows up as expected in iOS under the “SPEAKERS & TVs” list, but when I select it and then attempt to play something in Tidal, I get an iOS error dialog titled “AirPlay” with the message “Unable to connect to “Lounge [RoPieeeXL]”” and an OK button. I have to repeat this process every time and then the second connection request seems to work.

I’m using the latest stable version of RoPieeeXL on a new Pi4 and the latest iOS (13.3.1 beta 2). Happy to help debug.

Harry, unrelated, but perhaps helpful feedback: three minor setup issues I encountered and partly resolved after re-reading the docs a few times: 1) I initially tried booting the Pi while connected to a TV via HDMI and then a computer monitor, assuming there would be config options. The screen kept turning off after the Linux boot sequence. It wasn’t clear to me that the screen output was disabled by design. Perhaps this should be clearly highlighted for first-timers? 2) I also somehow didn’t notice that the initial boot sequence was performing setup activities and would restart a few times and ultimately take up to 5 minutes to compete. When I finally found reference to how the flashing display light worked, this all fell into place for me. 3) The ropieee.local domain doesn’t seem to work for me (although I can connect via the IP). Anyway, hopefully some of this is helpful from the perspective of someone sort of technical who’s just setup a Pi and RoPieee for the very first time.

Hello @Mark_Henderson. I appreciate the feedback from a new user’s perspective. Welcome to RoPieee!

Assuming that you read the RoPieee Beginner’s Guide, please help me improve the guide:

Any thoughts on how to make this easier to understand?

@spockfish Harry, regarding the AirPlay issue reported above, I’ve done a little investigating to see if the AirPlay issue might be upstream. I couldn’t find reference to which library you’ve incorporated into RoPieeeXL, but assuming it’s SharePort, I’m wondering if it might be the wifi power saving mode causing the first connection attempt to always fail:

WiFi powersaving is disabled.

1 Like

I’m having the same issue. Recently I started using airplay to listen to some soundcloud network streams from my iPad (that I use to control Roon). I have to try 3-4 times and then it will work indefinitely until I hit stop/pause. If I go too long, it’ll disconnect where I’ll have this issue again.

At one point I figured it was Roon bridge taking priority, even though I’ve played no music in Roon. I tried clearning out the queue of music to no avail. The only trick is to try 3-4 times. I can play to any other airplay device in the home without fail (Apple Airport Extremes, Integra AVR (non apple device)).