Ropieee XL trouble playing Spotify


I have just set up RPI 4 with Ropieee XL.
Everything works fine except when trying to find ropieee in spotify under “connect to devices”
I am only going to use it with spotify at the start so don`t have roon yet.

Anybody that can help?


Tested Moode.
Worked fine with spotify when used Wifi.
Don`t get wifi on Ropieee…??

In the network section can`t find anything on wireless.

Add images

WiFi has nothing to do with Spotify…

Anyways, is this a Pi 4? I’ve just pushed out an update that adds the latest CPU revision which is used for detecting wifi support.

Thanks for reply! :slight_smile:

Yes its a brand new PI 4. The trouble was spotify could not detect PI when on LAN. Tested with Moode and with PI on wifi spotify detected it. But on Moode the usb soundcard did not work. Ended up with Volumio, also had to use wifi to get Spotify to detect PI. Here soundcard is working so its all fine.

I do like the easy and simple setup of Ropieee XL.
Did you update this today just now so I can give it a new shot?

Probably the issue for Spotify not detecting PI on LAN is trouble on my network.

Yes, update is out there since a few hrs.

Problem solved!
Installed Ropieee XL again this morning and works great on wifi playing Spotify.

I`m impresed how fast you solved the wifi issue!
Great job!


1 Like

Harry is a machine…donations are always welcome to support his super powers.

So I did a small donation. :slight_smile: