Ropieeexl acting as a DHCP server?!

I’ve had a long standing problem in my system, where roon when say talking to tidal would time out etc.
I thought it was a roon problem but support pointed me the way to a dhcp / network problem.
Had me scratching my head for a long time. I had no other DHCP servers on my network than my Wifi / router.
Occurred to me that I did have one other server on my network- ropieeexl on my roon endpoint.
I turned it off. Suddenly roon+tidal worked! At least in one test.
Is it possible ropieeexl is acting as a DHCP server? I don’t see anything to configure through its web interface…

I ssh’d in and looked for process “dhcpd” and none was found. So confusing. But no denying that when ropieeexl is running it makes roon + tidal unhappy. Thoughts welcome!

Are you sure that there isn’t a simple IP conflict? RoPieee does not act as a DHCP server.

Try rebooting your router/wifi and then all of your other networked devices (assuming nothing is statically assigned).

Hmm, did some network debugging.
My imac had a DNS server setting of I must have set that in the past.
That’s google, so should work fine. But I was having some DNS lookup failures.
So reset it to (my internet router).
Rebooted etc.
Now seems to be much happier.
Not sure why ropieee off would make things happy and with it on made it unhappy.
Not sure why DNS server setting caused problems.
Doesn’t make much sense.
But that one change seems to have made roon talking to tidal happy. So I"ll be happy.
Hopefully it stays happy. Thanks for the thoughts…

Well, back to unhappy.
Tried out some stuff later this evening and back to roon core having weird tidal-access problems if my ropieeexl is turned on.
Seems independent of whether it’s my currently selected roon endpoint.
Turning the rasptouch + ropieeexl off and roon got happy.
Can’t explain it but definitely happening…

Following up, as discussed in another thread.
The Ropieeexl had its DNS resolver hard wired to Not sure why.
I configured it to use my gateway (or get it from DHCP).
That seems to have resolved all of my roon-talking-to-tidal issues…

I’m confused.
I looked at the network config on my two endpoints - one is Ropieee (static IP) and one is RopieeeXL (DHCP). Neither one has any place to enter a DNS server in the network setiings. Where are you setting this?

Not via the GUI.
I googled how to set DNS resolvers on linux and then poked around. I think I ended up changing it in two places:

   10  cd /etc/systemd/network
   17  vi
   18  vi /etc/systemd/resolved.conf 
   19  cat /etc/systemd/resolved.conf 
   20  cd /etc/systemd
   21  cp resolved.conf resolve.conf.orig
   22  vi resolved.conf

[root@ropieeexl ~]# cat /etc/systemd/network/








[root@ropieeexl ~]# cat /etc/systemd/resolve.conf.orig

# This file is part of systemd.


# systemd is free software; you can redistribute it and/or modify it

# under the terms of the GNU Lesser General Public License as published by

# the Free Software Foundation; either version 2.1 of the License, or

# (at your option) any later version.


# Entries in this file show the compile time defaults.

# You can change settings by editing this file.

# Defaults can be restored by simply deleting this file.


# See resolved.conf(5) for details



#FallbackDNS= 2001:4860:4860::8888 2001:4860:4860::8844







Although double-checking, looks like it’s been automatically set back to in /etc/systemd/resolv.conf. Not sure how to permanently change it. I guess I’ll keep mucking unless someone has the answer…

The above changes didn’t stick, and my ropieeexl is back to using as the DNS server (as far as I can tell) and somehow that’s causing roon to be unhappy talking to tidal.
Would appreciate help with:
installing nslookup
permanently changing the DNS server
Thanks in advance…

That’s all not necessary. If you update to the latest version then the Google DNS is gone.


Ah, great, thanks. What command can I use to confirm which DNS server is being used?

cat /etc/resolv.conf

It should only mention your router.

If you have touched these files before there’s a chance this is not populated. In that case I advise a reflash.