RopieeeXL - AirPlay lost volume control

Hi there fellow Roonians!

I‘ve been successfully running Allo USBridge Sig with RoPieeeXL (version 3.088) on it and was able to stream via AirPlay to it from 3 different iPhones. Volume control is set to „software“ in the Shairport and everything worked flawlessly. I was able to control the volume from the phone connected via AirPlay or when streaming via Roon - using DSP volume.

Today I started some music in Apple Music on my phone, tried to adjust the volume as usual, but it didn’t work.

I checked the settings, tried setting up volume control as “none”, committed the changes and rebooted RoPieeeXL. Then returned the volume settings back to “software” (committed, rebooted). No luck :frowning:

Roon DSP volume keeps working just fine. But AirPlay volume doesn’t work. Tried streaming from different phones.

Nothing similar could be found here in the threads as far as my search can tell.

Anyone had similar issue? Would appreciate any recommendations on where to look next for possible fix.

Thank you!

The issue persists even after reflashed SD card with a fresh RopieeeXL copy :frowning:

Anyone experiencing same lack of volume control via AirPlay?

It’s unclear to me what you want to achieve or hope to find. Screenshots show that you use USB output which means there is no hardware volume control.

Hardware volume controll works only when using a HAT and if the HAT supports volume control.


You are correct, Harry. No hardware volume is allowed since there’s no HAT. I was only using iPhone volume control while streaming via AirPlay which worked perfectly fine until recently. Now volume control on iPhone doesn’t work. Tried different phones, rebooting/reflashing Ropieee - no volume control over AirPlay.

Hey Harry,

Could you please take another look at the issue? Here’s what my setup looks like:
Allo USBridge Signature running RopieeXL 3.088 with
USB out to Chord Qutest (no hardware volume control)

When I just started using Roon around 5-6 weeks ago, I was able to use iPhone volume control when streaming via AirPlay along with DSP volume when streaming via Roon.

Now DSP volume in Roon works great as before, but AirPlay streaming has no volume control from either of the apps that can pass their audio from iPhone via AirPlay.

When switching from, let’s say Apple Music app, to Roon, to try to use Roon’s volume control, the audio stops (as if the stream is getting ready to switch from AirPlay to RAAT).

Below are my current settings. All other streaming options (UPnP, Squeezelite, etc) are turned off.

It’s still very unclear to me what you’re trying to do.

What do you mean? Are you streaming Airplay via Roon? Or just Airplay OR Roon? Because in the latter they are totally not related to each other.

What do you mean the audio stops? When you switch streaming technology that is what happens as the audio device first needs to be released. In most cases you need to wait for a few minutes before the audio device is released.

So to get it clear for me: you say software volume control does not work when using Airplay?

Thank you for getting back to me, Harry.

When I say “stream via AirPlay”, I mean selecting AirPlay as audio output on my or my wife’s iPhone. Roon app is not involved here in any way. Just start Apple Music or Youtube app on iPhone, select AirPlay output and press play. So it is always AirPlay OR Roon in my setup.

I mentioned the use case when audio stops when switching from AirPlay to Roon, because I was reading other posters on this forum saying they were able to control AirPlay volume from Roon, which is not my case. Sorry if that got confusing. The fact that audio playback stops on the switch is 100% expected here.

Volume control does not work when streaming via AirPlay.

Appreciate the recent RopieeeXL update, Harry!

I’ve installed 3.094 version on my Allo USBridge and tested AirPlay streaming from 2 different iPhones (iOS 14) and Macbook Pro (Catalina 10.15.6).

Software volume control is set in the Shairport-Sync, but volume change on either of the Apple devices does not change music playback volume.

The settings are below on the screenshots.

Could you please point me at any direction how to troubleshoot this?
I was really enjoying being able to adjust volume on my phone when streaming via AirPlay.

Thank you!

Hi Harry, wanted to share a quick update to the issue, which could be useful for further troubleshooting. I tried installing another SD card in my USBridge streamer, which made it run Moode player. When I stream to Moode from those same AirPlay devices, software volume control does affect music playback volume.

Hi Harry, appreciate you publishing 3.113 update for RoopieXL! I’ve upgraded my USBridge Signature to it, but unfortunatelly, the software volume still does not work when streaming via AirPlay from any of my iOS devices.

Here’re the screenshots from the XL setup:

I tried changing SD card to one with Moode player, and the volume works just fine when streaming via AirPlay. When I put RoopieXL card back to listen to Qobuz via Roon, it works great as a Roon endpoint, no issues whatsoever. But when I try streaming via AirPlay, the playback is stable, all functions work great, but I can not change playback volume on my iOS devices - playback volume level is fixed regardless of volume settings in Apple Music, Youtube or any other app that can AirPlay audio content.

Would appreciate you recommending further steps for troubleshooting.

Thank you!


@spockfish Harry, hope you’re having a nice week so far. Would appreciate you taking a look at the updated input on the Airplay volume issue above. Thanks in advance!

It’s difficult to get a look at this. I don’t have any i-device.

Is there anyone else who can verify this?

I just tried playing IDAGIO on my iPhone 7 and sending audio to RoPieee XL using AirPlay, iPhone volume control works fine … if you set in ShairportSync Volume Control on Software

1 Like

Thank you for chiming in Stefano! I do have ShairportSync volume set as Software, but nether of my iOS devices can change volume of the playback while streaming via AirPlay, unfortunately.

1 Like

… realized just now …. we have different setup, mine is a rpi4 while yours is a CM3 … this could be a hint…

what’s interesting, when I just started using RopieeeXL, AirPlay volume worked just fine as I shared in my original post. Then w/o any obvious reason the volume got fixed on all my iOS devices when streaming via AirPlay. @spockfish Harry, maybe there is any logging I can share with you which may provide further clue on how to fix this? Thank you!

1 Like

Hello Stas – were you able to resolve the problem? I had a similar experience… airplay volume as played through Apple Music etc. worked fine, and inexplicably stopped working after, and honestly, I don’t remember if there was even an update, but I think there was as I remember rebooting the device and the volume control was gone. I have tried setting the volume settings as you have, but there’s no change, iOS volume just doesn’t work anymore. I wonder if it’s a setting change, or if an update of alsa or some other linux service has broken the volume control.

Edit: apparently setting a zero volume on Apple Music (MacOS, iOS) works to mute the music, but any other change doesn’t work.

Edit #2: since I am digging around on this issue, I have found another user for whom volume control IS working as of January of this year. Link to the forum post is Ropieee volume issue - #75 by DanMtsn

Hi enbee, nope, unfortunately I wasn’t able to fix the volume on ropieeeXL. Switched back to Moode and happily using it for both AirPlay and Roon streaming ever since.

By any chance, do you remember when you started using Ropieee & when volume control on iOS stopped working? I am digging through the release notes trying to figure out if there’s a change that may have broken it. I will also check out Moode, does it work on RPi…

I created the original post here right when the I noticed the issue for the first time (see my top post in this thread). Moode works great on RPi. Ropieee was the easiest in terms of installation and setup process, but Moode has been more stable for me long term.