RopieeeXL and HQPlayer NAA

Hi, after some extensive googling and a whole lot of luck, I was able to install HQPlayer NAA on my RopieeeXL! And it works!

Since it involved a lot of trial and error and I’m a complete Linux noob, I don’t have step by step instructions to repeat the process, but here are the general steps.

  1. ssh into RopieeeXL
  2. create a new user since root cannot “make” packages
  3. add this user to the sudo list
  4. install a package called debtap using pacman. deptap converts .deb packages to something that can be installed on arch linux
    4b) as root, run debtap -u to update debtap data files
  5. download the latest naa .deb package from signalyst with wget
  6. follow the debtap instructions to convert the .deb file
  7. install NAA
  8. use systemd to start NAA on restart

I know step by step instructions would be much more helpful, and if I get another pi 4, I can try to document the steps more carefully, but at this point, I’m hesitant to change anything!

One thing to mention is during the HQPlayer make process, I encountered some errors, but I just plowed through and in the end, I got a file that installed properly and is working (eg, it’s recognized by HQPlayer and plays fine). I’m not 100% sure, but the only different I can tell is the volume appears to be louder than using the Dietpi install on the same Pi 4 and same DAC.

One question is what happens when RopieeeXL updates itself? Will that erase all user changes?

Have fun and enjoy!

Hi,

If things go as planned this will land shortly.

Thanks

So is NAA the next XL option for installing?

Not that noob it seems anymore

yes, that’s the plan.

2 Likes

Assume we will see this in the beta channel in due course then :slight_smile: not that I need NAA just yet but its another feather in the Ropieee hat so to speak. Defaulted to Off I assume too.

yes and yes :stuck_out_tongue_winking_eye:

Nice one Harry @spockfish like the custom clock…10 mins still not elapsed to see if I can get a darker blue :slight_smile: And the NAA is in there too

Edit …Damn just saw the timeout option…awesome Harry…just keeps getting better

1 Like

NAA implementation works perfect in a first test.
Switching from (and back) NAA to Raat, DLNA and Spotify work.
I use a Raspberry 4 for the first test here.
Very nice.
thank you Harry!

1 Like

One more thing

After using HQPlayer you have to deactivate the NAA used (like switching to another NAA or Asio) in the HQPlayer settings. Otherwise, RopieeXXL remains stuck with NAA.

1 Like

I notice the same thing. However, this does not happen when using Dietpi. Eg., I can switch between raspotify, NAA, Roon bridge and Shairport-sync no problem.

Btw, which version of RopieeeXL has Harry’s install of NAA? I’m still using the image I manually installed NAA on (was worried updating will erase everything).

Thank you!

It is Version 20200212-1

Thanks…is that a beta version? Mine does not update past 20200211-1.

But when I tried the beta version, my system was stuck with the need to reboot banner so I switched back to stable.

this is the latest version from the beta channel

Thank you! Reflashed the sd card and now it updates properly!

I have HQPlayer NAA activated on my USBridge Sig and it works like a charm with HQPlayer!

RopieeeXL version is 2.464

RopieeeXL is great!

1 Like