RopieeeXL becomes unresponsive and/or missing periodically

New user here. I tried searching the forums for existing answers, but none seemed to apply to my issue. Would appreciate any suggestions. Thanks!

Here is my setup: RopieeeXL (latest build) installed on Raspberry Pi 4 (CanaKit) with USB output to Schiit Modi 3+ DAC to Fosi BT20A Amp. Ethernet is not plugged into the Raspberry Pi and RopieeeXL has been configured to connect over WiFi.

I first set it up as a Roon endpoint about 3+ weeks ago, and have been using it without any issues throughout the 2-week free trial period (an old Macbook Air served as the Roon server).

Once the free trial period expired I set up the UPnP/DLNA with USB output (and software volume control on) and have been experimenting with playing Tidal tracks via BubbleUPnP and MConnect Lite on my OnePlus 7Pro and also iPad Air (original or 2G I think). Everything seemed to work fine at first. The problem is that the RopieeeXL seems to disappear periodically from the UPnP device list in both apps on both devices (MConnect only for iPad; AFAIK, there is no iOS version of BubbleUPnP). Furthermore, sometimes the RopieeeXL web interface is unresponsive - i.e., the website times out and I can’t ssh into it either. A reboot fixes the problem, and everything works for some time before the same issue occurs again. Sometimes the web interface is responsive, but I still can’t see RopieeeXL in the device list of the UPnP apps. And sometimes the RopieeeXL magically reappears on the device list. And to complicate things even more, sometimes I can see the device in one app, but not in another.

Just sent feedback in case spockfish can help (a56d30d5a38268e4). I’ve been really enjoying the experience when I was using it with Roon. Would like to thank the dev(s) for their great work on this.

Hi @Jin_Seok,

You forgot to mention that you’re on WiFi :wink:

Anyways, the logs seem pretty ok. I suggest you switch to cable and see if the problem persists. Let’s make sure this is not a WiFi issue.

Thanks

Thanks for the quick reply. I will try connecting via ethernet to see if the issue persists. If this does solve the issue, I am curious how a WiFi issue would selectively affect performance for UPnP only (given things worked without a hitch for 2 weeks on Roon). Does the Roon server establish some kind of permanent connection to RopieeeXL or wake it up, so to speak?

Update: Seems like this is in fact due to some WiFi issue. Everything seems to work great when I connect the Raspberry Pi to my router via ethernet cable. When I disconnect the cable and try to connect via WiFi, the RopieeeXL web interface becomes unresponsive again and I lose RopieeeXL from the device list in UPnP apps. Furthermore, when I ping the device, I’m getting lots of dropped packets. Thanks spockfish, for helping me isolate the problem!

Does anyone have any suggestions for how to resolve these types of WiFi connection issues? The Raspberry Pi is literally sitting next to the router (Netgear Nighthawk), so I think interference can be ruled out. Perhaps my Raspberry Pi has defective WiFi? However, this doesn’t explain how the WiFi connection worked flawlessly for 2 weeks when I was using it as a Roon endpoint.

Well,

The Pi has not the best wifi. What I find interesting is that you have a 4 (which has a substantially better wifi chipset then a 3) and that is located next to the router.

You could try with an external USB dongle, or better, a wifi bridge.

Update #2: I grabbed a spare SD card and threw a Moode Audio image on it. My thought was that I could test UPnP over WiFi functionality with different software to test whether the cause of the WiFi problem was hardware. And so far it seems to be working great with no unresponsiveness to the web UI, and the Moode device is always visible in my UPnP apps on both iOS and Android devices. I think this rules out a WiFi hardware issue.

At this point, my only guess is that the RopieeeXL software got corrupted (or maybe that SD card got jacked up somehow). I will have to re-image the card with a fresh copy of RopieeeXL to find out and report back here in case others are curious.

Any update? Am intrigued by how moode is working for folks.