RoPieeeXL bluetooth volume

I am running XL version 3.094 on a Raspberry Pi 4 Model B Rev 1.4 with the Hifiberry Amp2 hat. Roon works very well. I chose “HAT” under Audio Output on the Bluetooth tab. When I connect my Android phone or iPad to the device via Bluetooth, audio is very low volume. Am I missing a setting I need to adjust, or do I need to attach a separate USB Bluetooth streamer to the Pi to be able to stream Bluetooth audio from my phone or iPad outside of Roon? Thanks.

1 Like

So when you connect your phone did you check the volume level on your phone?

On Android at least (but I assume on iOS as well) you have volume control separately for bluetooth. So you need to just increase volume on your phone. That’s it.

Thank you. I have the Android Bluetooth volume all the way up, but output is still low when connected via Bluetooth, as compared to using Roon or Airplay. Just wondering if there’s a setting within the Pi software, possibly, to adjust the volume out. Not a big deal at all, but there’s an app that I’d like to use that supports Chromecast but not Airplay, and I thought I’d give Bluetooth a try with it. With both my iPad and my Android, I can hear the output, but the volume is very low. Thanks for all of your help and for the great software.

So what kinda output do you use? a HAT or USB?
And in case of a HAT, what volume control do you have configured?

I’m using the HifiBerry Amp2 HAT. Controlling volume through Roon. Here’s a screenshot of the setting page. Untitled|690x350

Yeah, ok but I meant your bluetooth settings.

This is all I have under the Bluetooth tab in XL:

And here’s a screenshot of my Android playing Tidal via Bluetooth. Bluetooth volume on the phone is all the way up, but output is low.

Same problem here but I am using USB output.

And update on this?

Any idea anyone?


I encountered the same issue today. Streaming via Bluetooth from an EchoDot to a Pi4 with Hifiberry Amp2.
Is there a solution?

Maybe this is a workaround to increase the Bluetooth volume level. Use the roon app to adjust the volume. Then stop playing music from roon. Connect the Bluetooth transmitter to the pi4 and start playing music.

Do not forget to disconnect before playing from roon again.

1 Like

Yeah this would be an interesting experiment.
I’m curious though to what’s going on with @Juan_Bonnett as he’s using USB.

I tried it and it worked.

I would like to clarify that my issue is not with roon. Only when I send audio from my phone.

Clear. But have you tried the above?
And can you show your device bluetooth volume?

That was the problem… I had Roon volume at 30. Change it to 100 then switch to bluetooth and it sounded fine for any app.



This worked for me too. Thanks everyone!


I have the same problem (also Hifiberry Amp2). The roon workaround works, but if you like to switch sources Roon - Spotify - TV (over bluetooth) regulary it’s a littel bit frustrating and you’ll always have the risk to blow your speakers if you switch back to roon and get the 100% loudness. Or do I miss something?

I can’t test it anymore, because I just switched back to HifiberryOS, but maybe my mistake was not using “device volume” (or however it is called) after reading this post