RopieeeXL doesn't scan/detect wifi on an RPi3

Hi all,

I’m trying to use wifi on a RPi3. Installed RopieeeXL without an issue but after pressing the scan button no wifi network is displayed. After this, I installed Ropieee on the same RPi3 and the network was detected after pressing the scan button. (Same thing with the latest 08-14 version, as with the previous version).

So, it seems I have an issue with the RopieeeXL image. I downloaded another copy but the issue stayed. Anyone else heving this issue and hopefully a workarround? Any pointers would be appriciated.

Thanks in advance, Martin

I’m running a RoPieee XL/rpi4 [2022.08.1 (524)] and Wi-Fi network is detected , then the issue could be due to the use on rpi3

Hi Stefano,
Yes, strange enough Ropieee has no issues on the same RPi3, wifi scan works. Looks like this is an XL-image for RPi3/Zero2 with the issue. (This is a different image than the one for the RPi4.)

Harry @spockfish will find the issue for sure, send him a feedback (from the Advanced tab)

1 Like

@spockfish ed4f48be8a843160
Thanks for looking into this issue.

Groet, Martin

If I look in the logs I see you don’t have your interface set.
Hence no wifi…

Thanks @spockfish , there is indeed no wifi, but the interface says otherwise:
Status 1 - wifi disabled
Status 2 - wifi enabled toggle and configured
Status 3 - result of pressing scan button.



I re-downloaded the image (compressed and uncompressed), but still the same issue.
Strangly enough, the Ropieee image has no issue. Once i toggle the wifi, it detects and selects automatically the correct wifi network.

Log: 2d2f9af0d57ac26f

Greetings, Martin

That’s weird.

There is no difference between the 2 versions on this level.

It’s a little bit clear form the logs what you are doing, but this is what you should do:

  • enable wireless
  • go to the wireless tab and select the interface (there’s only 1 in your case)
  • hit the scan button

Ideally after this you send me feedback.

Same result, as in the screenshots I sent you.
As you say, I would also not expect any difference between the XL version and the non-xl version. However, the non-xl version works flawlessly.

Just tested the XL-version with a wifi dongle and it detected all local networks.
Now, after removing the dongle and a reboot, the onboard wifi detected the network!