RoPieeeXL is here!


I just released RoPieeeXL: the extra large version of RoPieee that provides additional streaming technology next to Roon. For now this is DLNA and Airplay, others may follow.

To start with let’s make it absolutely clear that RoPieeeXL still is the same as RoPieee: this means that the basic principle “this is an appliance, not an OS” still holds. If you’re looking for that then RoPieeeXL isn’t for you. This is also the main reason why this is a separate entity from RoPieee: keep RoPieee as simple as it is for those that just want a Roon Ready endpoint.

If you like the simplicity of RoPieee but wants to use other streaming technology then Roon, then RoPieeeXL might fit your needs. You only do Roon? Then there’s absolutist no need to upgrade to XL.

So how does this work? First of all there are XL images available, next to the usual. The software has the same base, so an update to RoPieee is an update to RoPIeeeXL.

Next to the separate images there’s an easy way to upgrade from RoPieee to RoPieeeXL by means of a simple setting in the ‘advanced’ menu of the webpage. Keep in mind that this is a one-way route: once you’re upgraded to RoPieeeXL there’s no way to get back.

The upgrade option becomes available in RoPieee after your unit has been upgraded to 336 and has rebooted once again. If you can’t wait for that you can always download the RoPieeeXL image from

Keep in mind that if you’re installing it directly from the image the hostname won’t be ropieee, but ropieeexl

RoPieeeXL provides an additional tab in the webpage labelled ‘RoPieeeXL’ where you can find all related settings. Right now they are about selecting the right output, others may follow.

And finally I’d like to thank the guys testing this over the last months, needing to deal with me breaking stuff once a while :wink:



Just saw this - and I have to say, finally! I was building my own custom upgrades to do this some time back on another RPi distro - Thankyou!

Do we need to be on beta to see this feature? I just downloaded the RoPieee XL image and I still don’t see it after a couple of reboots.

My Ropieee has been upgraded to version 336. there is only a wired section on the Network tab. Tell me where the Wifi connection settings went, how do I return them?

Harry, I don’t see this option anymore in v336 of my non XL devices. Is this normal behaviour?

Even after a reboot?

1 Like

What do you expect to see? You should have an extra tab in the webpage labelled ‘RoPieeeXL’.

There’s no need to switch to beta, that was the whole point of this release :wink:

What are you saying? That you had wifi and after the update it’s gone?
What kind of hardware? Can you send me feedback?


Rebooted all four 336 normal RoPieee again.

Nothing about XL on the Advanced tab.

Can you send me feedback of one of those?

Yes, of course.


Can you reboot this unit? It should show up now…

also no XL tab here… identifier f3a5bd0f3695f6e1

I am trying out the XL Ropiee software.
I use RopieeXL in a Raspberry 4 and a HifiBerry DacPlus

Some observations:

Works fine with Roon.

RopieeXL is recognized with Audirvana Windows but fails to start playback. (Error starting device playback)
RopieeXL is recognized with JRiver Mediacenter 25 Windows but fails to start playback. (There was a problem controlling selected DLNA device)

Have you tried DLNA straight after a reboot? So without using Roon first?
And have you looked at the output settings in RoPieee’s webpage?

1 Like

I tried Roon first.
Then I did a restart before trying Audirvana and JRiver.

Not familiar with both. Tested with another DLNA stack.

So did you have a look at the output settings? What are you using? USB DAC or HAT?

I used USB DAC

RopieeXL is recognized with BubbleUPnP in Android. Playback failed.

That’s what I use too…

Can you send me feedback? It’s on the ‘advanced’ tab in the web page.