Ropieeexl on RPi4b + HifiBerry DAC2 HD + Touchscreen Crashing

Hi all,

I just setup a brand new Ropieeexl on RPi 4B with the HifiBerry DAC2 HD and the official RaspberryPi Touchscreen. Everything works and sounds terrific for about 30 minutes and then the Pi crashes/shutsdown. I’ve had it crash in as few as 5 minutes and run as long as 40 minutes but it always crashes eventually. All I’ve been able to see on the screen is quick scroll of text but not enough to see if there were any error messages.

Temp on the RPi is a consistent 56.0’C.

I’m not really sure how to proceed with debugging this. Has anyone else seen anything similar?

I logged in as root but didn’t seen anything in the raat or roonbridge logs.



I run this exact setup and don’t have any problems. Not helpful but at least it’s a datapoint to let you know that it should work fine.

Some shots in the dark:
Are you using the raspi 4 power supply to the Y connector for display and raspi? I recall that the raspi 4 power supply is a little bit beefier than the pi 3 and is needed to power both display and pi.

Check - disconnect and reconnect - each of the connectors to make sure display cables, power cable, and HAT are properly seated.

With the display case I’m using there’s an optional cover that has a cut out so a HAT can be added with the cover in place. For me that cover doesn’t work with the HAT because of the surface mount components on the bottom of the DAC. If you are using the cover then that could make it hard for the DAC to seat properly on the pi.

I’m running a bunch of hats sitting on top of my rPi 3B+, and I feed 5V from a supply through the hats. I found out that the GPIO pins are rated for 2A based on the manufacturer data sheet. I was getting the lightning bolt on the display even though my power supply was rock solid at 5V and capable of 4A. I would reseat the hats and the lightning bolt would go away for a couple weeks and came back. I ended up soldering directly to the rPi and the problem is done.

But keep that in mind depending on how you power your pi.


Thanks to Douglas and Sheldon for the replies. I did some experimenting and also tried your suggestions of checking power and reseating things. It seems I may have a suspect Rpi 4.

The Pi and HAT work fine with no shutdown for over a day.
The Touchscreen and an old Pi 2B I had laying around, also work fine and run over a day.

However, the Touchscreen and the Pi 4, with or without the HAT, and even powering both the Touchscreen and Pi directly, result in a shutdown in anywhere from a few minutes to 30 minutes.

So, since the Touchscreen is working with the Pi 2B, I’m suspecting something in the Pi 4B video section is at fault.

I am having one other issue unrelated to hardware and I’ll create a new post for that but while I have your attention here… I can’t seem to get the Touchscreen to update to a new album selection unless I restart the extension. Maybe I’m missing something.

I don’t remember if I have this problem with the RPi4, but on my TV screen (HDMI), I click play once and the music starts. I have to click play a second time to get the screen to update. I have no idea why, but it’s just an annoyance.

I rarely have a problem with the album not updating. When I have it was usually related to some playing around I’m doing that causes an endpoint to have a hiccup like network configurations. In normal day to day it works well. I’ve seen the display have to refresh but again that was related to some playing around I was doing with native DSD playback that was causing some streaming errors.

On my home network I use Google WiFi and I set the various Roon components to reserved IP addresses. I seem to recall some problems with displaying content before I did that with a new raspi endpoint but not sure if I’m remembering correctly.

It’s been a while since you posted this so I’m not sure if you found and solved the problem, but I have similar behaviour on a 4b with an Audiophonics DigiPi+ HAT wired LAN. I ran Moode for several months and didn’t have this problem (but had others) but pretty much from the start with RopieeeXL it freezes after 30 minutes or so, then I need to reboot to get it back (control points report no response from renderer). Mostly I’m running radio streams but never more than 24bit 48kHz WAV.

With Moode, I don’t remember it ever freezing once playing, but I had a significant issues with control points detecting it on the network.