RopieeeXL Rpi4 not seen on JRiver

I posted this in another thread but because i am a newbie here, apparently i can only reply 3 times. Since i reached that limit and did not get the help needed, i had to start a new thread. Sorry if this violates the duplication rules.

Havent yet signed up for roon but am planning on my 2 week trial this weekend if I can get this ropieexl issue resolved. I have my roon server setup and am getting my other things in order so that when i do begin the trial, i can be spending time listening rather than setting up.
I have a pair of wireless speakers that get their signal from a wisa hub that is not roon approved … yet. so, i decided to put a rpi4 with ropieeexl in front of it so they can be seen by roon (when it is finally up).
I decided on the xl version because i currently use jriver and thought i would test out to see if it worked with JRiver. The installation of ropieee went fine as did the upgrade to xl. I adjusted my setting in the xl, dlna tab but jriver cannot see it, nor can i see it in windows network explorer (not sure if it should but most other dlna devices show up). The ip is static but tried dhcp but neither worked. I am very confident it is not my setup in Jriver as i have been using it for many years and know how to navigate and setup for dlna discovery. I have attached dozens of dlna devices on my network and it has never had a problem with any ot them. While we cant discount it completely, its highly unlikely its not jriver. This same rpi4 using volumio is discovered and functions perfectly using jriver.
If @spockfish would confirm he got my feedback from Friday and let me know what he sees, i would greatly appreciate it
feedback sent 991e7bfc456a3f04

Hi @cd_gibson ,

It seems that there’s a corruption on your SD card.
So either reflash or try to upgrade to beta (in the hope this will correct the corruption).


I dont see beta available for download nor do i see the xl version (it is only available by installing regular and then upgrading). i will use the same image as before and upgrade.

Reflashed on new sd card and so far (at least with Jriver) it is working
Thanks for your help