RoPieeeXL Spotify on Allo Digione

Just switched from Dietpi to Roipeee on my Digione and have a problem I’ve not been able to resolve. First of all Roon and DLNA are working just fine. But I’m unable to get the Spotify or Airplay service to appear in the system selectors on corresponding software.

In Spotify app I can see my Librespot enabled SOTM streamer, my Sonos One speakers, and the Echo dots scattered throughout my house. But Spotify on Roipeee XL is a no show.

Any guidance on resolving this?

How did you set the output?

I’ve tried AUTO, HAT, basically every choice and carefully committed changes and rebooted all with no change.

I’ve done totally clean reinstalls of Spotify on clients, tried from various clients and no success. I find it odd that the SOTM with LIbrespot which is connected to network exactly like the RoiPeee endpoint works just fine.

Can you send me feedback? It’s on the advanced tab

Thanks for taking a look Logs have been sent to RoPieee HQ with unique identifier ca64e964a67ab762

BTW, how can I look at the logs myself. I have SSH enabled.

Can you disable all other services? And only leave Spotify enabled with audio output set to HAT?

Oh. BTW, can you switch to the beta channel? You can do that in the advanced tab.

Made suggested change and switched to BETA channel and applied the update. No change in behavior.

Logs have been sent to RoPieee HQ with unique identifier 98d226d8d907fa04

Looking at the logs to me it still seems you’re on stable and not beta.

It’s on Beta I sent the log before I rebooted but it is indeed on Beta. Behavior is identical to stable release: Roon Bridge and DLNA work fine, Spotify and Airplay not.


Logs have been sent to RoPieee HQ with unique identifier ac5cdfeaa13a793d

That’s weird.

So… I’ve updated the Spotify component and added some stuff to the logs being sent.
But for my idea: what do you exactly mean with “Spotify don’t work”? Does it show up in Spotify as available device? And when you try to connect to it what then?


Yes it’s odd. The RoPIeeeXL Digione Spotify service doesn’t show as an available device on any Spotify client I try. And as I mentioned what’s weirder is that the SOTM-SMS200 on my network that uses Librespot service for Spotify does show up and works fine. It’s on the same network and connected exactly the same as the Digione.

Logs have been sent to RoPieee HQ with unique identifier ee90791e1f7779a9.

Hmmm… maybe we’ve been looking from the wrong side then. This might as well be an infra thingy.
That explains why I’m listening to Spotify all day without problems :wink:

Anyhow, can you do the same test, send me feedback, but disable UPnP and Shairport? So only Spotify enabled?

I understand the complexity of troubleshooting a problem like this given all the possible variability in network configurations, hardware, etc. so I appreciate your efforts.

Everything disabled except Spotify attempted to discover Roipeee Spotify service on Iphone, Ipad and Macbook pro Spotify clients the service does not display on any of them. Alf of my other Spotify aware devices appear as expected, Sonos, Librespot, Echos, etc.

Logs have been sent to RoPieee HQ with unique identifier 94a44d8a7f4901c4

Also as a point of curiosity, when I configured Librespot Spotifiy support on the SOTM-SMS200 there is a configuration screen that asks for Spotify user credentials. How does Roipeee accomplish this function?

Yeah… this is an interesting part.

Right now I’ve never had the need to do that, as long as the controller is logged in. So, in my case, I have Spotify runnning on my phone and desktop. There’s it’s logged in (you need to be premium user to use this functionality anyway), so then there seems to be no need to log in on the device side.

But the documentation on this part is not entirely clear.

HI @TonyV,

I made an error, so there’s another bugfix available.
When we’ve got this figured out I owe you a beer :wink:


Spotify Connect or whatever they call it seems to be a moving target.

Other way around I’ll owe you a donation for the great work and support you do.