Rotel USB pops and clicks

Hi there,
Happy Roon user here.
My set-up:

  • NAS with flac, DSD
  • Roon 1.3 build 262, stable (64bit), Linux, Intel NUC I3,
  • NUC connected by USB to a pre-amp Rotel RC 1590 (USB 2.0, DSD capable)

Using Rotel RC 1590 USB input: each time I play a file I can hear two audible pops/clicks just before the track starts.
Issue occurs with all formats; flac (44.1 and hi-res) and DSD
When I swich to networked endpoint (Hifiberry), connected on the same pre-amp digital (Coax)…no pops.

Any suggestions/solutions?
Thanx in advance!


If you use the usb into the raspberry pi (not sure what RPi build you are using) if it can see the dac there does that help?

Pops and clicks causes are different. ‘Pop’ is normally associated playing back DSD when the source send a ‘PCM silence’ and the DAC somehow process this as DSD data, resulted in a nasty pop. Click is normally happens when sampling rate change or changing from PCM to DSD or vice-versa. It can also can be hardware dependent due to muting circuitry. Clicks are normally harmless but not for nasty pops.

This is a very common reason for artifacts around the start of playback. Not all DACs mute themselves properly during transitions.

Sometimes adding a “Resync Delay” in Roon’s device settings helps–this causes Roon to pump a little bit of extra silence through the system when starting playback, which sometimes is enough to hide whatever is going wrong with the hardware.

I don’t think anyone here has experience with Rotel hardware firsthand, so hard to know what is/isn’t normal. Maybe someone else in the community does and can comment on that product specifically.

Using Ropieee on a Pi 2 now, that solved the USB identification issue😁
The pop/click issue remains though, with or without Ropieee in the USB chain (NUC > Ropieee > Rotel RC 1590)
Any thoughts?

Sounds like maybe it’s the Linux driver capability in either the NUC or RPi then…if you try Roon Bridge on say a windows laptop does that work with an ASIO driver?

@everybody: thanx for your replies/suggestions etc, much appreciated

@Wizardofoz: with Ropieee identification thingy is solved, but pops keep coming through
@Musicear: You’re right, no clicks but pops (occurs each time I change sample rate/change from PCM to DSD)
@Brian: Thanx, tried ‘resync delay’ and adjusting max sample rate etc: no effect, issue persists.
@wizardofoz: I’ll try my win 10 laptop tomorrow and let you know.
This issue might also be related to the RC 1590.
Using the same setup on a Lyngdorf TDAI 2170 and a Rotel RA 1570: no probs.
I’ll pm Rotel tomorrow. lets see what they’ll say…

I have a new RC 1590 that has the same issue. NAS to MacMini as core. DAC pops when sampling rate changes. Any feedback from Rotel? Solve the issue?

1 Like