Router change causing problem

Hi, I have recently updated my system router and now Roon is not seeing my totaldac on it’s connected page, only as an Airdrop item. Any clues how I can get it to find it again please

Hello @Derek_Suggate,

Thanks for contacting support, I’d be happy to take a look over this issue with you.
I have a few questions for you before I can be able to properly advise on next steps:

  • Can you please let me know the model/manufacturer of your new Router?
  • Can you let me know more information regarding your Core? Operating system and model/manufacturer would be helpful
  • Are you using any switches in between the Router and the Core?
  • Is the Core connected over WiFi or Ethernet? Directly into the Router or into a switch?
  • What model TotalDAC are you using?

Please let me know your reply when possible and we can continue troubleshooting from there.


Hi Noris

Thanks for coming back to me. I have answered your questions below in red. I hope that’s enough info for you, please let me know if not.

I am also trying to find a solution via totaldac themselves so far without success

Hello @Derek_Suggate,

I am unable to see your response to my questions, if you are using email to reply it is possible that only the part after my response is received and posted on our site.

Please submit again in it’s entirety with my response as the reply or reply directly to the post on our Community site for your thread, linked here: Router change causing problem.


1 Like

Hi Noris

Hopefully the answers below will help, if you need more info please let me know.

Can you please let me know the model/manufacturer of your new Router?
My Router is a Sagecom (Orange Livebox 4).

Can you let me know more information regarding your Core? Operating system and model/manufacturer would be helpful Roon is installed on a Synology DS416Play.

Are you using any switches in between the Router and the Core?

Is the Core connected over WiFi or Ethernet?
Directly into the Router or into a switch?
Via Ethernet cable.

What model TotalDAC are you using?
It’s the D1-7.

Hello @Derek_Suggate,

Thanks for re-posting your answers. You mention that this issue only has started occurring with the new router, correct? And using the previous one was working fine and there was no other changes to the system you made?

I believe that this issue could be caused by the multicast settings on that new router. We have an article on our internal Knowledge Base that discusses Networking Best practices link is here:

I would double check your Router settings to see that you have “Multicast” enabled and if you see the option for “IGMP Proxying/Spoofing” I would try toggling that option on/off as well to see if it helps. If the router has a firewall, it is also worthwhile to see if you can add Roon to the exceptions list using the manufacturer’s instructions. Please let me know if any of those options are available for your new router and we can continue from there.


Hi Noris

I don’t seem able to access any of those settings on my router. However, it does seem as if there may be a problem with the SD card in the dac and I am awaiting a replacement to see if that’s where the problem lies. I’ll get back to you if it still looks like a Roon issue. Thanks for your speedy responses

1 Like

Can you fit your old router back in as a test?

Unfortunately the upgrade to the router meant that the old one went back in exchange. It’s now suspected that the problem may not be Roon related but rather the SD card in the dac. Thanks for the suggestion

No problem, hope the dac SD card resolves the issue.

Hi again Noris

Well, there was a problem with my DAC, but that has now been sorted. Interestingly, when I reinstalled the DAC into the system, Roon was able to see it, but when I tried to play something I was getting a message that the file was loading too slowly. I re-booted the NAS to see if that helped and since the re-boot Roon now only sees the DAC via Airdop but not by the usual means. Any clues please?

Well, now Roon is not even seeing the airplay option of the DAC! Yesterday it could see this option but still wasn’t able to play anything. Something very strange is going on. I desperately need help with this. Even the history page on settings has disappeared. All that I am able to do on Roon is to see the albums on the NAS

I am able to access and play files direct from the NAS on my AVR in the TV system, so am guessing that the problem doesn’t lie with the NAS

But wait! Suddenly Roon has seen the DAC, but still can’t play files…message is “Roon: An audio file is slowly loading-May indicate a performance or hardware problem.

Any idea what is happening here, it just feels like one problem after another

Just tried again and this time Roon cannot see the dac! Is this looking like a problem with Roon on its SSD as the problems are coming and going and are not constant. I would really appreciate some help from support please…I just want to be able to play some music

Hi @Derek_Suggate ---- Thank you for the updates! The additional feedback is greatly appreciated and my sincerest apologies for the delay here.

Before we continue the troubleshooting process I want to be 100% certain that we are on the same page so I can advise accordingly on the situation at hand. As it stands currently D1-7 is not being recognized by the application at all, is this correct?

Furthermore, may I very kindly ask you to please verify the IP addresses assigned to both the DAC and the device hosting your Roon core (ie Synology DS416Play)?


Hello Eric, thanks for getting back to me.
Yes, currently the D1-7 is not being seen, although it was earlier today when i then received the message about slow loading (see previous postings).
The IP address for the dac music server is and for the NAS it’s

Hope that helps. Is there any likelihood of corruption or damage to the NAS SSD as the situation seems to be changing regularly?

Hi @Derek_Suggate ---- Thank you for the follow up and the feedback. Very appreciated!

Based on your follow up I can see that the IP addresses assigned to the DAC and the NAS hosting your core are in different ranges:

DAC/Music server =
Roon Core (i.e NAS) =

This is almost certainly the reason why the DAC is not being seen by the application. I would recommend assigning the D1-7 a static IP address.


Thanks Eric…I’m sorry, that was a typo! It should have read 168 as per the server

Hi @Derek_Suggate — Thank you for touching base me! I appreciate you clarifying that for me :sunglasses:

I would like to propose the following. Let’s try temporarily hosting the core on another device just to confirm if the D1-7 can be seen by the application when the core is residing elsewhere. This will help us narrow down where the error is occurring (i.e the core VS the network). Before performing this test please make a backup of your Roon DB first just for good measure.

Looking forward to hearing your observations!

Hi Eric, I don’t know how to do that so will need your guidance please. It does seem odd that it can see the D1-7 from time to time but loses it when i try to play any music. I’d have thought that this means that the route from Roon to dac is actually ok