Router Firewall Pinholes for Roon and RAAT

Core Machine (Operating system/System info/Roon build number)

Dell XPS 15 laptop

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

U-Verse 50 Mpbs ethernet connections

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

U-Verse router - USB - Dell XPS 15 - RAAT - Oppo 203 - HDMI - Bose Soundtouch 300

Description Of Issue

Everything is working fine, just slow to load, expecially 24/192 files. I opened pinholes in Windows Defender firewall for Roon and RAAT, but just remembered that my U-Verse router has a hardware firewall. In looking at opening pinholes there, it is asking for protocol (TCP or UDP) and Port number or Port range (from XXX to XXX). Please advise what these settings should be for Roon and RAAT. Thanks.

Your router isnt involved. Layer 3 rules would only apply if you were routing RAAT through the router out to the Internet. But you’re not (especially since Roon doesn’t even support it). Connecting multiple devices to the LAN side of the router (as most home consumer devices have 4-8 local LAN ports) is layer 2 switching, not layer 3. The switch chip used in these devices does all the forwarding at the ASIC layer; it never even wakes up the router CPU…

OK, thanks.

Hi @James_Fitzgerald,

I would really suggest changing the router as we have often seen issues with ISP provided routers (as mentioned in our Networking Best Practices Guide).

Even a fairly inexpensive consumer-grade router may help with these issues (TP-Link/Netgear/Asus) and the UVerse router can be placed into Bridge Mode and the router can facilitate the communication.

I know you mentioned that you have a direct Ethernet cable in your previous thread, but if the router is still not up to par it might be causing some of the issues you are seeing.

I’m reluctant to mess with my U-Verse router. In addition to a wired TV and Slingbox, I have two wireless TV receivers. This is not something I want to fool with. It works very well for everything including Tidal and Qobuz. Thanks.

1 Like

Evidently, AT&T U-Verse routers do not allow bridge mode for various reasons. They do allow something called passthrough. Would that serve the same purpose? This MIGHT be something I look at in the future. Seems like the same results could be achieved by making a pinhole through the router firewall for Roon, if I knew the settings.

Hi @James_Fitzgerald,

From what I have been able to gather on the AT&T site, it looks like pass-through mode is very similar to Bridge Mode, so it should help but do note that I have not used this specific router type before or have configured it in such a way in the past.

Opening up your firewall in the current router is unlikely to help as I believe the issue is more-so related to your ISP router’s ability to process the bandwidth for sending the content. I would try a standard consumer-grade router from a place that support easy returns such as Amazon and see if it helps.

Thanks, but I’m not understanding how that would work. I cannot get rid of my U-Verse router. All I would be able to do is somehow add a second router in series with my U-Verse router. I have no idea how to do that. Also, any signal going to the second router would have to pass through the U-Verse router. How would this help? I’m not questioning your suggestion, just trying to understand. Thanks.

By the way, Roon is running smoothly this morning.

Hi @James_Fitzgerald,

Yes, this is correct. Once you add the second router, the ATT UVerse would be acting as a “Modem”, meaning it just converts the Coax/Fiber cable coming in to a usable Ethernet connection. Then by deactivating the WiFi on the router and setting it to passthrough mode, all the communication for your Core, Endpoints, Remotes would occur on the new router.

I am curious to know when the next issue occurs, can you let me know the exact local time + date when you observe this behavior? I suspect it might be a buffering issue, but I can enable diagnostics once I have a timestamp and see if there’s more underlying info.