Rpi 4 falling off roon


Player w Pi2 hat occasionally disappears from Roon. Comes back soon but is paused. This is intermittent. All devices are hardwired ethernet, not a loading issue and not a heat issue.
Probably unrelated but shutting down W10 laptop pushes this player into pause ?

This happens to me with an RPi 3+ once every second day or so. Music stops abruptly, play indicator in Roon continues on for a while and then ropieee disappears as an end point. After maybe 1 minute it returns and I can continue to play music.

Ethernet connection.

Not sure what is failing here, if it is my internet connection or the ropieee installation. Who knows.

in the network tab i can see the ip address. If it falls off and returns with a diff # then a network issue.

It happened again as described here by me. Sent feedback: 2fe96fec0d3806f7.

RoonBridge is crashing every now and then.

It is being restarted, so that’s the reason why it comes back quickly.

This happens seldom, so I see 2 options: 1) ask support to have a look or do a reflash (something might be corrupted, although I can’t see anything out of the ordinary in the logs.

Oh. Considering the frequency it might be an option to set RoPieee’s daily reboot (at night for example). That might be an option to ‘fix’ it.


Harry out of curiosity I had this exact issue a month or two ago, Ropieee with a Hifiberry DAC+ with phono outputs into my Sonos Amp. Music would be playing and then just gone or I would look for the device to play to and it would not be there and then a few minutes later or would reappear.

I never got to the bottom of it but I still have the device (if you wanted me to run any tests on it), though it is no longer in use (as it was a little project I was working on)



As mentioned a crashing RoonBridge is very rare.

Could be the case in your instance too, but to verify it you need to have it run (and play audio) for some time and then send feedback.


Thanks for taking a look at my case. I will follow up with your suggested actions here. Was not aware of the possibility of the scheduled reboots.

Harry I don’t need it at the moment so I will leave it. Just wondered if it you see more of it then I would be happy to plug it back in if you needed something non production to test and break in case it is some kind of edge case issue.


Thanks Mike,


In general I’m (trying to be) very conscious about issues with RoonBridge itself, because that lies outside my influence window (besides triggering the Roon folks oc).


1 Like


Same for me here, 3 RPI4 do not work with Roon
I got Ropeeexl with touchscreen. Ethernet for the 3 units…
It used to work until this morning.
I am reporting the pb as i can not access from the web ropeeexl local.
Any thoughts?


Have you restarted your Roon server?

Yep, but as i can read in the forum people with Ropeee have same pb as device Linked to ropeee is showing in Audio section but not in playable zones…ticket is open but strange as it was working great with 1.8…
But the weird stuff is i can not access Ropeee in local to check is something is wrong

Just fyi, my player is shut down most nights and rebooted in morning.
The issue does not relate to Roon version, happened before and after recent updates.

What do you actually mean?

You can’t reach RoPieee’s webpage? Have you tried the IP address directly?

Your logs shows serious dropouts, so I suggest you investigate your network.


Thank you, will investigate with my supplier.

Yes this is it. I tried and page does not load
I restarted the 3 RPI with Ropeee XL but nothing
They are all with ethernet connexion and as Nuc Core and all other devices work with ethernet connexion I assume it does not come from Internet nor Roon as it works on AirPlay or with core directly plug to Dac to amp…

Anyway i won’t bother you on a sunday
I ll try to restart again Core then RPI and i ll see

Same issue. Submitted feedback b4129541fda1a7ca

Restarting Roon Core not necessary, but changed some RoPiee settings and it showed up again in Roon Core. No IP address change as I am using a static IP and the web-console for RoPiee.