RPi 4B, RoPieeeXL with HifiBerry Amp2 - No Sound

I just purchased a RPi 4B with a HifiBerry Amp2 HAT. Flashed the micro SD card with RoPieee and assembled everything. I can log into RoPieeeXL and adjust settings. On the Roon configuration page I have the Audio HAT set to HifiBerry Amp2. I can see the RaspPi in Roon and have it enabled. As far as Roon is concerned it seems to work…in other words the song looks like it’s playing but no sound from the speakers hooked up to the Amp2. Similar situation with Spotify Connect. I can see the RaspPi and can select it. Song seems to play but no sound. Sounds to me like a problem with the Amp2 HAT. Any thoughts or help any one can provide??

Hi David. I just set up exactly the same configuration for a friend of mine and all seems working fine (same equipment and same software)
Did you check some basic stuff like loudspeakers or power connections and AMP2 volume?

I just double checked the speakers. They work fine when when attached to another amp. Thanks for that idea.

Power connections seem fine. The RPi works (I can log into it) and it gets power through the AMP2.

Not sure what you mean by AMP2 volume. Is there a place in RoPieee to control that? In Roon volume control is set to device volume.

Thanks for taking the time to think about this!!

Asking for the obvious of course, but you have the volume up in Roon?

Yes, volume is up in Roon.

Hmmm. then I’m seriously wondering if the HAT is broken.

Can you send me feedback? You can find that option on the ‘advanced’ tab.
Just follow the instructions.


I’m thinking the amp is broken too. Would be super helpful to hear your thoughts after looking at the feedback! Will send it later today.

Feedback sent. 3cf834d4c30a16f2

I appreciate your help!

Hi @David_Frantz

Looking at your logs I see that you have enabled all XL services.
For the sake of debugging I suggest you disable everything so we can test with just Roon.

So disable all XL services, play some audio from Roon (and let it go for a few minutes), and then send me new feedback.


Turned all the services on just trying to flip every switch to get it to work. Turned them all off now, and played some audio for a few minutes. Tried adjusting volume in Roon. Still no sound. New feedback: 663a19e30065cb32.

Thanks Harry!

Hi @David_Frantz ,

Thanks. The logs look perfectly fine: I can see that you played around with the volume and Roon reports that it is actually setting volume.

I’m slowly starting to think that there’s something wrong with the hardware…


Thanks Harry. That’s very helpful. Now I have to convince the hardware manufacturer that it’s their problem. They think the issue is RoPieee and want me to install HifiBerryOS.

Of course they do :slight_smile:

But in all honesty: that would still be a good test. The problem with HifiBerry is that, since they have their one OS, they tend to spend less energy in ‘making stuff compatible’.

So in fact it could be a RoPieee issue.

Thanks. That makes me feel better about investing the time it will take. I’ll try installing HifiBerry OS and report back.