RPi to DAC not showing as an endpoint

Grabbed the Jamo S801 power monitors recently to run a RPi with Ropieee into the them via USB input for a small bedroom setup. The DAC inside the speaker seems to not be picking up the RPi and it does not show up in Audio options in Roon. Am I missing something? Why wouldn’t a DAC with USB input see the RPi and report to Roon for an endpoint?

A bad USB cable is the most frequent reason. Have you tried a different cable?

Yes. I have tried a different cable…

It would be interesting to know what the RPi sees. You can ssh to it, then type “lsusb” to see if the Jamo speakers show up.

And in the RoPieee Web interface, under the “Roon” tab, is the “Audio USB” toggle on?

Sorry, but how do I get to the Ropiee web interface?

Go to your browser and type the hostname of the RoPieee unit. By default this is ‘ropieee’.

Can you please send me feedback (you can find that option on the ‘advanced’ tab) so I can have a look at the DAC?


Thank you! Is this what you need? f251b275385eb661

Yeah. Can you run the unit a little bit longer before you send me the feedback? It was still initialising so I’m not sure I’ve got everything with respect to the DAC.

Just let it sit there for 5 minutes or so and then send me feedback.


1 Like


The DAC is not properly initialised. Most probably because it does not support Linux.
You can contact the vendor, but I’m pretty sure what their response is going to be.

1 Like

Man… I really appreciate it. You have saved me so much time. I may return these for the Bluesound Flex 2i speakers which are Roon Ready or just run these with Roon through bluetooth or from my iPad with the proper cable. Thank you again!

Well, if you like the Jamo you could go the SPDIF route. A simple SPDIF capable HAT will do the trick.

A hat added to my RPi? What would you suggest? I have my Pi in the Flirc case…