RPI4 Ropieee - USB DAC popping sound - buffer

I’ve recently got into Roon and love how it’s improved my listening experience.

My 1st setup was this:
Roon Core - 2010 Mac Pro - USB - Audiolab M-DAC - XLR Balanced - Elac Navis AR- F51 Active Speakers

I’d had issues with popping noises even before using Roon, the Audiolab shows the USB Buffer on its screen and you can see when the bar drops low you get a pop in the sound. I was able to fix this using a USB hub and later adding a USB3 PCIe card to the Mac Pro allowed me to get rid of the Hub.

I’d watched a lot of videos online about using RPi to improve the sound rather than using a ‘noisy’ computer. I was also fed up of having to use my Mac to control Roon, I’d like to sit down and choose some music on the iOS App without needing my computer and all its displays on.

I have a 2011 Mac Mini my kids no longer use and a RPi1 sitting around so decided to try moving the Roon Core to the Mac Mini headless and using Ropieee as the Roon Bridge. I had decided I wouldn’t use the Mac Mini direct to the DAC as I’d read lots and lots about it not being good, the word noisy was used a lot.

You probably already know the 1st hiccup was my RPi1 isn’t compatible with Ropieee so I bought a 1GB RPi4. (The Pencoed factory where they are made is literally 5 minutes from my house but they don’t sell direct.) I decided to get this bridge working with my Mac Pro first to see how it sounded. Well I can’t really tell how it sounds as all I get is constant popping and the USB Buffer on the Audiolab is bouncing around all over the place. I’ve tried 2 different USB Hubs and changing all the settings I could in Roon but nothing has made any difference.

I’ve ordered a Hama hub that I’d read on Pink Fish Media helps with the Audiolab. While I was waiting for that I decided to try the Mac Mini, got a kit to add an SSD and got it working running core but just acting as a bridge for now. Plugged it in via USB with nothing else connected and it sounds great, I haven’t done blind A-B testing but an album I listened to yesterday sounds better today and the USB Buffer is rock solid.

My main aim has always been to get the best sound quality. I’m looking at better power supplies for the RPi and maybe a HAT to give me coaxial out. Of course going coaxial would fix all the USB issues instantly. So I wanted to ask advice, am I chasing improvements I probably won’t hear, should I be trying different connections from the Mini like optical?

The one thing I don’t have is a budget to change anything on my setup. I was very lucky to find an audiophile who’d made a mistake on the Elacs and let me have them half price, but my wife is still pissed off 3 months and a holiday to Cyprus later!

The main thing that stands out from your post is the discussion around ways to get around the shortfalls of USB into that DAC. That said, you have no budget so it is a mute point. @spockfish is there anything that can be done here?

Thanks for the response, I’ve seen other posts about USB popping noises when using RPi with Ropieee so I don’t think it has to be my DAC at fault, so for me it’s not a moot point :wink:
The other ones I saw suggested fixes like using a HAT to give a coaxial output, but that’s bypassing the problem, not really fixing it.

popping should only occur on Pi 3 (or 2). Pi 4 should be ‘pop free’.

Point taken! :slightly_smiling_face:
Popping isn’t normal though. One thing to note was that the M-DAC is rated to 96/24 which suggests it is Class 1 audio. I don’t know if that changed in later models. It is however academic if you have moved to another product.

I’m using the original M-DAC which does handle 96/24 over USB.

I tried to look for settings like “Max Hardware Buffer Size” and “Use Power-Of-2 Hardware Buffer Size” but I don’t see them in the device settings when using the Ropieee.

I’ve just updated the software to try the Beta branch in case that can help.

Edit: Ropieee version 368 still popping.

I’m not sure it will, but worth a shot I suppose.

but this is on a Pi 4?

This has to be a device specific issue. 96/24 should not be problem at all.
The DAC is directly connected to the Pi?

Frankly, I’d just go that way, if the fan on the Mini isn’t bothering you. They’re pretty quiet.

A lot of this talk about “noisy computers” seems to be largely hypothetical and somewhat FUD. Many of the conversationalists don’t seem to have actually measured the noise coming from their computer over the USB. In fact, the only one I know of is this one, which concludes:

There’s nothing bad at all! Within the audible spectrum, the i7 computer noise profile stayed below -140dB. No terrible noise spikes or unusual ultrasonic noise differentiating the i7 despite the fact that we’re looking at a moderately high-powered, older CPU using a typical multi-rail PC switching power supply with a powerful GPU inside with no attention paid to software audio or OS optimizations.

Following settings:

USB Buffer - just used to display the buffer which should sit at 50%, with Ropieee it’s about 10-20% and when it goes to zero I hear the pop.
Lsb Restoration - used only for Windows XP
D3E Decorrelator - off
Phase select - normal (0 deg)
USB Volume - accept control (I’ve tried it off, no difference)

When connected to my Mac Mini or Mac Pro with new USB card the USB buffer sits at 50% and no popping. If I connect to my Mac Pro’s USB2 ports I get 50% to start off with but after a while it drops down to the same levels I’m seeing with Ropieee and pops.

Ok. This is a device issue, so are there any USB related settings in the M-DAC?

is there a difference between the USB 2.0 and 3.0 ports/outputs from the Pi4?

I experienced this with an RPi 3 and the MDAC. Are you using the stock firmware on the MDAC? If so, search out the Lakewest firmware updates - there are posts from a couple of years ago on the Pinkfish site.

That firmware gives you more options and a bit of experimentation will leave you pop-free.


Thanks for the great reply.

Yes I updated it to the latest software when I 1st bought it as I was getting so many problems with my Mac Pro on it’s built in USB2 ports. In that case a USB Hub and then a USB3 card fixed the problem but I can’t fins any way to fix it for Ropieee, but it’s greta to hear this combination should be working.

Is there any chance you could let me know what your settings are, in the DAC and anything you might have changed on Ropieee?

No, exactly the same

Just to be clear- you are using the Lakewest firmware? Do you know which version (From memory there are three and the second one was best for some reason).

I’ll try to find the thread on Pinkfish and will look at my settings when I get a chance.

Thanks so much, if I hold down volume on restart it shows this:
Sottware(sic) Revision

I just tried to get onto the wiki page to confirm those are the latest but it’s running really slow.

Edit: I got through to the page and the latest version is A.10, I remember only going to A.08 because of something I’d read on Pinkfish about it being better. Anyway, updated to latest version but it made no difference to the Ropieee issue.

Ok - I’m using A.10, and there are posts on Pinkfish suggesting A.09 is slightly better sonically!
Post #8 here has links to the various firmware files (https://www.pinkfishmedia.net/forum/threads/mdac-firmware-update-or-not-that-is-the-question.195303/#post-3609603)

I’m not going to mess with the filter settings on my MDAC because I remember getting completely lost last time and there isn’t an easy way to just view the current settings without risking making an unwanted change!

If you use the search function on Pinkfish there is a post on there from the designer with suggestions. From memory, the key one for me was to set jitter rejection to ‘wide’ (or something like that). Otherwise, just change the settings to what seems right and have a listen. Good luck!

PS just seen an old post - set jitter attenuation bandwidth to ‘high’…

Thanks for checking. I’m afraid jitter attenuation won’t help, that’s only available for optical and coaxial inputs, not for USB.

I was on A.08 because A.09 wasn’t available to run on a Mac, only A.08 and A.10 are.