RPi4 with Ropieee not being recognised by Roon despite showing on network

Hi, I am trying to get Roon to recognise my RPi4 with Ropieee loaded on it. I am using a NUC as the core host, and it is connected via ethernet the RPi (at least physically). The RPi then goes via usb to an RME UFX II audio interface which I am using as my DAC. I was able to use this usb connection without any problems using my laptop, to use Roon, so I don’t think it is an RME issue. I have the Fing app for Android, and it shows that both roon core (NUC) and the RPi4 are recognised on the network. I have tried restarting ROCK, trying black (older) usb port on the RPi…

Any help appreciated.


Is the roon service started in your ropieee?

I have Ropieee XL on an RPi 4, so -

Are you saying that Settings==>Audio doesn’t have the Ropieee device?
(I renamed my Ropieee host to ‘Luna’, so don’t be concerned about that)

Can you access the Ropieee device thru a browser, using either its IP or Ropieee.local?

Don’t know about the standard Ropieee, but XL does that automagically.

Thank you for the quick replies. I don’t know how to tell whether the Roon service is started on the RPi. I can access it from a browser but it doesn’t have a ‘start Roon service’ option in the settings. Slim, Roon does not have the RPi showing up in audio - unless it is the ‘unknown device’ I can see - but when I named that “Possibly RPi” and selected it to play music, the music just came through my laptop’s internal speakers, despite my laptop already being recognised with a separately named icon in ‘audio’.

Does not mean that the service would not crash or have an issue. I wonder why there is no status of service for things like that. Going to install it and check it out.

Further information: it shows up in ‘about’, but not in ‘audio’. I have just tried enabling wifi but this hasn’t made any difference.

Hi Have you enabled audio USB in Ropieee general settings.

Steve, yes, audio USB is enabled. I have also updated the USB firmware in Ropieee and restarted.

No, there isn’t a setting like that. So, that’s not a problem.

Obviously, you’ve tried rebooting the RPI, so tagging @spockfish for you.

Hi @Will_Napier,

Can you send me feedback? It’s on the ‘advanced’ tab in RoPieee’s web interface.


Hi, yes the ID is adf335edbc225e28, sent just now.

I’m wondering whether it may have something to do with the fact that I first connected the RME UFX II DAC as the DAC for my MacBook Air. I now have a rather strange setup in the ‘audio’ section under audio/ThisMac, I have three: “WillsMacBookAir”, Un-named built-in output (CoreAudio), and PianoRoomDAC (CoreAudio). I find that I can play music through my Piano Room system (through the RME) from either “WillsMacBookAir” or “PianoRoomDAC”. Obviously what I’m trying to do is not to need to use the MacBook Air other than as a controller.

Edit: I also can’t group any of those three with anything else in the house. So presumably my Mac isn’t using RAAT. This would also explain why I’m only getting “High Quality” and not “Bit Perfect” icons on the signal tracker.

Let’s focus on the DAC for now. The reason it doesn’t pop up in Roon is simply because it is not visible in the Pi: from the Pi’s perspective it is not connected (and powered on).

I’m wondering if this is supposed to work, as their website does not mention Linux at all…

1 Like

oh @Will_Napier,

One more thing: have you tried a different USB port on the Pi? They differ (USB 3 vs USB 2), so it might help.

I have tried one of the blue and one of the back ports. I’ll try another. Maybe I am conceptually under-equipped as yet, but as I sit here I am enjoying my Piano Room system through Roon through the RME UFX II. But it is not as part of the whole house Roon (RAAT?) network, I suppose.

I posted on the RME forum before buying the Pi : https://forum.rme-audio.de/viewtopic.php?id=30097

They said the Pi would need to be CC Mode compatible. Could this be the issue?

I’m confused. You state that it doesn’t show up in Roon, but now you say that it works.

My apologies, I didn’t make clear that I was listening via my Macbook Air. The Macbook is currently connected via USB to the UFXII, being used as a DAC. What I want is to not need to use the Macbook, but to use the Pi, and control it from the Macbook or other devices. Please see edit to previous post also.

From the manual. The Fireface UFX II operates in two different modes: driver-based USB2 and Class Compli- ant. The latter describes a standard that is natively supported by operating systems like Win- dows, Mac OS X and Linux. No proprietary drivers are required, the device will be directly rec- ognized when the CC firmware is loaded. The natively available features will be limited in com- parison to those provided by the RME driver for the UFX II. For example there will be no hard- ware settings, no (Total) Mix and no settings for the effects
The Class Compliant mode can be activated and deactivated directly at the unit, as long as it is not connected to a Mac or PC: SETUP/REV, Options, Hardware/Diagnosis, Interface Mode, CC.

1 Like

Thank you Steve, that’s the issue. I now have the UFXII in CC Mode and am trying to work out how to get sound, either from headphones or through speakers. Looking at the manual now.

Is this a powered dac via a power supply or powered by the usb. Maybe if usb powered there is not enough power from the rpi supply

1 Like