Salkstream III: DriveNotReady errors [resolved]


#1

Twice now Roon has suddenly (today while in the middle of a song) stopped and gives me this message

Last time it did this it suddenly started working again after awhile (30 minutes maybe?).

I don’t know how to get it working again.

Anyone else have this problem?


#2

After about 20 minutes it suddenly started working again. This is aggravating.

Btw, MPad and my desktop computer (Windows 10) had no issue accessing my music on my Salkstream III, so I know the problem isn’t the streamer (Roon core resides on the Salksream III).

Roon controllers on my iPad mini 2, iPhone 6s, and desktop computer (Windows 10) all gave the same error message.


(Mike) #3

Hey @James_Kirkman – if you give us some details about your setup, someone from @support will look into this for you and see if we can figure out what’s going on here.

Thanks!


#4

I’ll do my best (computers are not my forte).

The Roon core is installed on my music streamer; Salksream III, which has an internal 2Tb hard drive which contains Roon Core as well as all my music files (about 5000 songs). The Salkstream III runs some version of Linux. The Salkstream III is connected to my home network router via an Ethernet cable.

My iPad mini 2 and iPhone 6s have the latest iOS software (10.2) and the latest Roon control software:

[Image removed at user’s request]

They connect to my home network via wifi.

My Windows desktop (Windows 10 64 bit) computer also has the latest Roon Control build (168). It is connected to my home network router via ethernet cable. BTW, I rarely use the desktop computer. 99% of the time it’s just powered off. I most always use my iPad or iPhone for control. Since the error message shows up on all 3 controllers, it seems something is going on in the Roon Core.

As I was typing this message it happened again. I opened Roon on my iPhone to play something and I got the expected Lost Connection error (it usually reconnects quickly), but it kept saying trying to connect before finally giving the message “this album was not found”. If I try to pull up any music it says it can’t find anything in my library. Connecting/reconnecting to the core when I start/pull up the app seems to be what triggers the issue.

Arrrg!!!


iPhone app looses connection to library
#5

Any idea what may be going on?


#6

Still no response? Disappointing… :frowning:

Knock on wood, Roon has been behaving lately, but how long will that last?


(Greg Stratton) #7

Hi James,

Mike was on holiday for that last while and it probably got missed.

Let’s flag @support again for a reminder.

Cheers, Greg


#8

Thank you. :slight_smile:


(Eric Stewart) #9

Hi @James_Kirkman ----- Thank you for the follow up and my apologies for the delay here. I can see that from your most recent post that things have been stable, which I am very pleased to hear.

In the event that you start noticing this issue again, I have provided you with a support ID via PM and instructions on how to get us some logs. Please perform the requested procedure and we will take a closer look.

-Eric


#10

Thank you. I’ll do that next time it acts up.


#11

Eric, I just sent you my logs and responded to your email.

This morning when I updated Core to 1.3 build 196 the problem came up again, except this time it’s been over 2 hours and not corrected itself like before. Btw, I updated to 1.3 a few days ago with no issue at that time.

EDIT: I just got notice my email didn’t go through. Here’s what I wrote:

Hi Eric.

It’s happening again so I just sent you the logs per your instructions.

This morning about 9:30 AM EST I updated Roon Core to 1.3 build 196 (I had already updated to 1.3 on the core, iPad Mini2, and iPhone 6s without issue the other day) and updated my iPad mini 2 and iPhone 6s to build 194. Since then Roon does not see my music collection like before, except this time it’s been a couple hours and it still isn’t working ( before it would start working again after 20 minutes or so).

Also on a new issue, Roon won’t let me update the controller on my desktop PC (Windows 10) to 1.3.

When I open Roon on the PC, I get a message Software Update Needed. Beside “This PC” it says “Check for an update”. When I click on that nothing happens. It also shows the Remote Core as having the latest version installed.

Your help resolving these issues is greatly appreciated.


(Geoff Coupe) #12

That happened on one of my Windows 10 systems as well. So I went to the Roon Labs web site, downloaded the Windows version of Roon and reinstalled it (over the top of the Roon that was already installed, but would not upgrade). That cleared the problem, and the Roon remote on Windows 10 is now the latest build.


Why is Roon ignoring my song genre tags?
#13

Thank you. That worked. The PC is now up to date (1.3 build 196).

Unfortunately the problem with Roon not seeing my music collection persists.


(Greg Stratton) #14

Hi James,

Can you post a screenshot of you Settings > Storage tab and also your Settings > Library tab?

Let’s flag @support

Cheers, Greg


#15

Here you go:


(Greg Stratton) #16

Hi James,

I believe this applies to you. Please read carefully and, if so, follow the instructions to Edit your storage location.

Cheers, Greg


(Eric Stewart) #17

Hi @James_Kirkman ------ Checking in with you here, to confirm that the logs were received and to see if any progress or new observations have been. Looking forward to your feedback, many thanks!

-Eric


#18

Thanks guys. I’ll do as suggested and report back.


#19

I did as suggested and initially it seemed to work: I looked up albums on my iPad and iPhone and everything seemed to be there. So I closed the Roon app on my iPhone and iPad and went into the room where my system is located to listen to some music. Now I am getting this message when I open Roon to play something (it appears on my iPhone, iPad, and PC)

Ugh…


#20

I rebooted my Salkstream III player now Roon seems to be working again, although now it’s a bit sluggish loading a selected album compared to what it was before. As a matter of fact, when I first updated to 1.3, I was impressed with how snappy the response time was; a selected album/artist/etc would load instantly. Now it takes a couple seconds.

Maybe it has to rescan my library or something causing it to slow down (looks like everything is there though)? Btw, I have Background Audio Analysis and On-Demand Audio Analysis set to OFF.

Thank you again for the help. I greatly appreciate it.