Sample Rate Conversion and hardware limitations

I am running RoonServer on a Mac Mini mid 2011 and transporting to an Auralic Altair. When I try to use the Sample Rate Conversion feature on the DSP Engine, Roon skips tracks and display the message “Roon: An audio file is loading slowly. This may indicate a performance or hardware problem.”. I tried DSD64, DSD128 and DSD256 with similar results.
Below are the hardware specifications of the Mac Mini where I run the server:
Mac mini “Core i7” 2.0 (Mid-2011/Server)
2.0 GHz Core i7 (I7-2635QM)
Is it time to upgrade my hardware or is it something else?

I have a haswell i7 processor in my linux box which serves as a Roon core, a generation after my Mac mini, which is a 2012 edition. So it cold be 2 generations newer than yours. It will only reliably up convert stereo to DSD128 and multichannel to dsd64 before doing as you have found.

So yes I’d say it is time to upgrade if you want to up convert to dsd. I’m trying it to see if I consistently prefer it before upgrading.


I’m using a Late 2014 Mac Mini with Core i5, and I can not successfully upsample 44.1 to 88.2 even (I’m ultimately trying to upsample 44.1 to 176.4). I also can not get other DSP functions working, such as Crossfeed. In both cases, audio is totally garbled.

For reference, Audirvana+ on the same computer is upsampling 44.1 to 176.4 just fine. So I don’t think this is a hardware problem. I think it’s a software problem.

Furthermore, when I look at my CPU and memory utilization during the DSP operations, there’s plenty of headroom: CPU is at 20%, and Roon memory consumption is only 400 MB.

One more bit of info, I am still running El Capitan. But that’s intentional, as I don’t trust newer OS versions. Anyone else running El Cap, or have you all upgraded by now?

I am experiencing similar issues as well, I can up-sample/covert DSD64 w/out issue, but DSD128 is a hit and miss w/ crackling and drop outs. Maybe time to upgrade as well…

Here are my specs running on a ReadyNAS_516/Linux

MemTotal: 16298140 kB
CPU: model name : Intel® Core™ i3-3220 CPU @ 3.30GHz

For reference: my NUC6i5 1.8Ghz (Skylake) plays up to DSD256 (just). I tried my 2016 MacBook Air as Core (i5 1.4Ghz (Broadwell)) – it misses DSD256, but up to DSD128 there’s no problem. All PCM rates up to 384Mhz are fine on both as well.

Maybe CPU generation plays a big role, but I’d expect a Haswell i5 to have no problems with PCM. As for the Sandy Bridge i7 (2011 Mac mini): I’m surprised it does not do DSD64. What does ‘Processing speed’ in your Signal Paths say?

The processing speed is 2x

That’s low(ish), but I believe I heard @brian say somewhere the danger zone starts at 1.3x.

Maybe he can shed some light on DSP performance on different architectures?

I actually don’t believe it is a processor limitation. When I check in the activity monitor, the processor utilization does not exceed 30%.

Also for comparison purposes, I run Roon Core on a mid-2011 i5 Mac mini, and I can upsample to DSD128 with the 5th-order modulator. If I try to use the 7th-order modulator, I get stuttering, and if I try to upsample to DSD256 … I can’t.

Edit: I should mention that since I’m going to a Linux-based endpoint (exaSound PlayPoint), I’m not using DoP.