Sample rate reduction when using Roon or Roon ARC on Sony Xperia 1 iv

Version 2.0 (build 1353) production Core

Sony Xperia 1 iv (aptX Adaptive at 96 kHz)
Focal Bathys Headphones

Hi - my first posting of a question!
I have just got a some Focal Bathys headphones (which I fully recommend) and all is working well. They can be connected via BT or USB using their own internal DAC.
If I play tracks 24bit/96khz tracks they play native when:

  • USB from Roon Core
  • USB from my laptop
    But when I use BT, connected via aptX Adaptive with 96kHz sample rate, the Roon and Roon ARC apps do not recognise this and think it is limited to 48kHz. Have tried every setting I can think of, but can’t change it.
    Does anyone have any ideas.
    Thanks,
    Phil

Turn on USB driver in ARC settings to use an external dac of any kind so if using USB to the Bathys. If you’re using Bluetooth it’s the operating system on the phone controlling that and not Roon it will output to the Bluetooth stack of device and that will report back what it accepts. Aptx will only do 96/24 when conditions are perfect on a crowded train forget it. Also you may need to enable that as the codec to use for BT on the phone. Also make sure you have arc set to play the original rates and its not set to Auto if on cellular.

Show a screen grab of your signal path in ARC.

Hi,
Thanks. When using the external DAC on the Bathys via USB using ARC on my phone, it works fine. It is only via BT on the the phone and the aptX setting is correct - but it still downsamples. Attached are three screenshots:

  1. The aptX Setting on 96kHz
  2. The signal path and
  3. The MUSE settings turned off.
    Thanks


Bathys are not reporting back to Roon that it can handle 96/24 over BT. I can send 96/24 over LDAC from one device to another in ARC so I know that bit works. Do the Bathys support 96 using Aptx adaptive as to me it seems like they don’t. Not all devices do. Check with Focal just because it supports the codec doesn’t mean it supports the higher rates.

I actually think it is the Roon ARC app failing to recognise that the aptX Adaptive is set to 96 kHz.
The Bathys seems to work fine from the Qobuz app to the Bathys, streaming at 96 kHz using BT from my phone. The screengrab shows that, even with aptX Adaptive set to 96, it only recognises it as 48 kHz…

How do you know where is it showing it’s sending 96 th the Bathys from Qobuz it’s app will only show the stream it’s pulling nothing to do with what’s coming out the other end.

If the headphones don’t support it you can’t get it higher regardless of what you set the phone to or is that setting in the focal naim app? The whole issue with these BT codecs is they are not always work to the full range on all devices either from the sending or receiving device. Unless you can proper show the Bathys receiving 96 from another source then it’s likey not ARC as it sees what it gets told by the Os and connected devices.

Edit Looking at it though it might be resampling for Android OS limitation of 48/24 and not for the lheadphones. Just tried it on my FiiO DAP to my Momentun 4 which support Aptx HD. It just shows the rate at which the DAC is reporting back in my case the DAC reports 384/24 so I get it upsampled to that and it just hands over to the OS. On an Android phone this would be 48/24. I am sure it didn’t do this last time I tried it but may be wrong.

Well the specs of the headphones are clear, bit you’re right no absolute proof, but to me all the issues centre on the Roon Apps not working effectively with my phone.
I have exactly the same issue when using Roon or Roon ARC with my WF-1000XM4 that can stream LDAC at 96 kHz. It still downscales, so definitely an app issue…

Doesn’t downscale for me on LDAC. I don’t have LDAC headphones but this is my FiiO dap
Sending BT LDAC to my Hiby DAP LDAC 96 is showing and no downsampling in ARC. It’s a Bluetooth issue but not necessarily ARC the problem. I would wager it’s the devices but then ARC isn’t always reporting my FiiO as the device either so could be a bug.

1 Like

The Bathys Apt-X Adaptive implementation is limited to 24/48.

2 Likes

Ah, that would explain it…
I use a wired connection for most of my listening, but it would be good to get the higher rate at some point.
I may try to contact Focal/Naim to see if they will update them, if they can.
Thanks

2 Likes

How do u turn on USB in Roon Arc?
Thanks

Its in settings.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.