Samsung Galaxy S9+ Remote Issues [Resolved]


Today I received my S9+ pre-order and its a great device :smile:

My phone previously was an S7 and the Roon remote app worked without issue but the S9+ cannot connect. The app finds my core and says connecting but says connection failed shortly after and loops.

Is this because its day 1 for this device and support isn’t there yet?




Anyone else having issues?

Question should rather be:

Anyone else already having a S9+ :smile:

1 Like

I see your point haha

Hi @Paul_Whittaker ----- Thank you for the report and sharing this observation you have made with us in regard to the S9+. The insight is very appreciated!

To help aide in our understanding of this behavior you are experiencing with the mentioned remote device (i.e Galaxy S9+), may I very kindly ask you to please provide the following feedback:

  • A brief but accurate description of your current setup using this link as a guide.

  • Please provide the specs of the Galaxy S9+ remote.

  • My assumption is that other remote devices are not having any issues but please confirm.

  • During your troubleshooting of this behavior have you tried…

    • Not only rebooting the core machine but also any relevant networking hardware as well (i.e router, switches, etc)?

    • Reinstalling the application on the S9+?

    • I did some searching around the community site and noticed we had another user experiencing some connectivity issues with their Galaxy S6 and setting the device up with a static IP made things function as expected. Can you give this a try and let me know if this action triggers a change in behavior with the S9+?


Hi Sorry for the delay I have had work and recently haven’t been well.

I have a HP Spectre x360 with an i7 8550U, 16GB ram and this is my Roon core. The Core is wireless and does not have an Ethernet port for testing. My library is stored on a Drobo 5N2 and is connected through a netgear switch to my virgin media superhub.

I have tested a Note 8 and the same issue occurs, connecting and immediately disconnecting and looping. I have sent back my Galaxy S7 but prior to this it worked flawlessly.

S9+ is Android 8.0 (not sure what spec you want)
Note 8 is 7.1.1

I dont know how to set the static IP for my phone but if I’m totally honest I don’t think I should have too. Its my understanding I should be able to open the app and have it find the core.

I have restarted all my gear and this hasn’t helped.



I have used Oreo 8.0 ajd 8.1 with roon controller without issues. I bought my wife a s9 yesterday and will test tonight.

No issues with my note 8, so it sounds like there is something quirky on your setup.

I don’t understand why this issue didn’t exist with the S7 using the exact same setup? I didn’t test the note 8 at that time though.

Any help is great Rob thanks

The s9 worked with no issues. I would reboot your core if you haven’t already. Are you able to make and mantain a lan connection to anything else?

Additional thoughts now that I am on a full keyboard;

Reboot core, ensure S9 has wifi and LAN IP (I would set phone to airplane mode and then toggle Wifi on to ensure that you are not being routed out via LTE/cellular due to some obscure device setting)
if still not working, download “Fing” from app store, and run lan scan. Ensure both core and s9 show up as available. If you are on the LAN, and can see the core and s9 via Fing and it is still not working than it is something more complicated.

1 Like

Tank you for touching base with me and taking the time to answer my questions @Paul_Whittaker, both are very appreciated. Hope you are feeling better.

@Rob_Rodier, you took the “words right of my mouth” with your suggestions lol :+1::clap: Paul, if you are unable to test with a static IP address as suggested in my previous then I would try the following:

  • Put the S9 into “airplane mode” and then enable WiFi. What is the experience like?

  • Download FING to scan for available device on your network. As Rob points out, the S9 and the core machine should both show up in process.

Additionally, what is the experience like when you perform the following troubleshooting tests:

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote


1 Like

Hi I am much better thanks.

I’m not sure what I am using fing for? I know my Core IP and know its on my network as its connecting to my SOtM SMS 200 ultra and playing music.

I was able to change my phone from DHCP to static in its own settings and I couldn’t connect to my core still, as before I can find it but cannot connect it keeps failing (its allowed in the core settings).

Test 1 - My phone located my core then failed to connected a few times and then said looking for remote libraries

Test 2 - As the first test it locates the core right away but cannot connect. Connecting… then connection failed. looped. then back to looking for libraries.



Hi @Paul_Whittaker ---- Thank you for getting back to me with the observations made during your testing. The insight is appreciated!

Continuing forward, did you by chance give the proposed “airplane mode test” a shot, just curious what the outcome was there. Additionally, can you verify the exact model of netgear switch you are implementing?

Furthermore, have you tried adjusting what Wifi channel your devices are connection to? If you need “longer ranges” with your devices I would recommend 2.4ghz, but if things are in close proximity I would use the 5ghz as it is has more bandwidth.


Hi @eric sorry forgot to say the airolane mde does the same. Finds the core, tried to connects and fails looped.

My router is set to its default setting with all devices having full signal.

Here is the switch that connects the streamer to my router. My core (laptop) can find my NAS and Streamer without issue each time though.



No worries @Paul_Whittaker, thank you for sharing that information with me. Appreciated!

These types of issues with remote devices are often hard to nail down because in order for us to gather logs the remote must be able to get into a state where it can not connect to the core and then must be able to re-connect to send logs so we can look for any errors in the traces from that time period.

I am going to enable diagnostics on your account as this action will automatically generate/upload a diagnostics report containing a set of your Roon logs the next time the application is active on your core machine. Perhaps we will see something in core logs that can give us a clue as to why you are experiencing this trouble with the S9+. I will be sure to let you know when the report has arrived.

Lastly, in the past I have seen the use of jumbo frames cause some issues with remote devices, can you please verify for me that this feature is not enabled on the core machine, router, and the switch being used?


@eric what are jumbo frames and where I look to check?



Hi @Paul_Whittaker ---- A few things moving forward…

I checked our servers this morning and it looks like the mentioned diagnostics have not been received yet. Just a friendly reminder that this action will only be fulfilled when the application is active on your core machine next. I will keep an eye out.

A quick google search of “What are jumbo frames” had the following information to offer…

" A jumbo frame is an Ethernet frame with a payload greater than the standard maximum transmission unit (MTU) of 1,500 bytes. Jumbo frames are used on local area networks that support at least 1 Gbps and can be as large as 9,000 bytes."

Uses and limitations (the second paragraph sums up the concern here)…

" Enabling jumbo frames can improve network performance by making data transmissions more efficient. The CPUs on switches and routers can only process one frame at a time. By putting a larger payload into each frame, the CPUs have fewer frames to process. In return, this can reduce the amount of heat the network devices generate."

“These gains are only realized, however, if each link in the network path – including servers and endpoints – is configured to enable jumbo frames at the same MTU. Otherwise, performance may actually decrease as incompatible devices drop frames or fragment them, the latter of which can task the CPU with higher processing requirements. Enabling jumbo frames may also increase packet loss rates.”

I did some research on the Virgin media superhub and while it is unclear to me which model you are using I came across the following on the Virgin website:

Jumbo Frames causing Superhub 2ac to drop all internet access?

Jumbo frames causing superhub 2ac to disconnect internet

Being as the Netgear switch is unmanaged, I don’t believe jumbo frames are available on the unit so we need to check the settings on your core machine. Please try the following:

  • Bring up the “device manager” window.
  • In the list you will see to the left hand side of the window there should be a section called “network adaptors”.
  • Hit the drop down arrow to reveal the subcategory.
  • Right click on each of the possible selection and choose “advanced”.
  • In the advanced tab verify if JUMBO frames is present and enabled in any of the possible selections.


Hi Eric,

I haven’t used Roon since we last spoke adaptor seeing your reply I have had the application open for 15 minutes with the hope that’s enough time for you to get your diagnostics back.

I cannot find Jumbo frames in the advanced tab of my wifi adaptor (Intel AC 8256). If it helps I have a Virgin Media superhub 2 AC.

If Jumbo frames was the issue then would it be safe to say my S7 wouldn’t work either? Its a shame I don’t have access to it test anymore (Samsung took it back).

If you need more time for my info to upload let me know, though I will be using Roon for a few hours tomorrow at least.



@eric Has it been uploaded yet?

Hi @Paul_Whittaker ----- Thank you for touching base and giving the proposed test a shot, very appreciated!

Yes, the report has been received and I have passed it over to our tech team for review. I am hoping to receive some feedback from them soon and will be certain to touch base as soon as your ticket is back in my “support queue”.

Additionally, may I very kindly ask you to also please provide me with the IP addresses of your core machine and the S9+ remote in a PM.