Scaling issues on new iPhones[Solved]

Hey @razzi,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your remote device is connected to the Core a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Done. I’ve opened the application

Same problem here. I just updated from an iphone 8 to the new XS and the roon app has scaling issues…
Tiny tiny fonts and also overlapping with system notifications / icons, especially on top left.

Hey all – we’re aware of the issue and we’ll get this right.

It should be straightforward but it will require a new release of Roon, which will also need Apple’s approval for the App Store, so sit tight.

We’re on it, guys. Your patience is appreciated.


Same issue here. Strange it shows up on the new phones but didn’t become apparent with iOS 12 came out earlier in the week?

Just got an iPhone XS, and this is a problem. Very tiny text, buttons unusable in the top left corner. Any ideas? iOS 12.0. The text is at the very lowest limit of what is readable.@support


Read above, be patient, that means wait,

1 Like

Hi. Just got an iPhone XS and the Roon interface is unusable. As you’ll see from the image below, it’s like the entire interface, which needs to be scrolled on my old iPhone 6S, was shrunk down so the whole thing fits on the screen at once. The XS has a big screen, but nowhere need big enough to make most of the type legible. All the controls at the top of the screen are gone too. Am I doing something wrong?


Hi Jeffrey,

I’ve moved your post here. Please check out this thread.

Cheers, Greg

Roon on iOS12 iPhone XS unusable. Font too small and all the way up next to the notch. Please advies. Can I Chang setting? Cheers!

Hey Frank,

I moved your post to here. See @mike’s comment above:

Sorry about that. Tnx!

@support . Just got the new iphone. Roon is microscopic and I can’t make it bigger. I did not have an X but was under the impression it worked so am notsure why this would happen. Help? Or do I have to use an Android phone for remote?

working on it… just got my hands on one.

1 Like

I also have the same issue with the new iPhone XS


Installed roon controller on the iPhone Xs.
The resolution is way too high, doesn’t support the notch.
Can’t see any letters on the screen, too small :frowning:

Could you please fix it?

Hey @roon_lover_007,

I moved your post over here – see the comments by Mike and Danny above,

Hey @anon52323635,

I’ve moved your post over to this thread tracking the issue. Please see the comments from Danny and Mike above — The team is currently working on this we will be sure to update you as soon as more news is available.


Same issue here on iPhone XS.
Please let me know if I can be of service in terms of diagnostics info etc.
Otherwise I’ll just follow this thread and wait with baited breath.

Thanks for working on this!

Following thread