Scanning for Devices Misses Many (e.g. Marantz SR8802, Sony A80J, etc.)

Roon Core Machine

QNAP TS-853 Pro

Networking Gear & Setup Details

Nighthawk X4 R7500v2

Connected Audio Devices

The following devices showed up spontaneously…
Oppo 4K BluRay (Roon Ready)
Yamaha (via AirPlay)

Number of Tracks in Library

8500 tracks

Description of Issue

From the interface on my PC, when scanning for devices to add, I don’t find a couple that I think should show up. One is a Marantz SR8802A AV processor, and the other is a Sony A80J OLED TV.
Other devices (as mentioned in the “Connected Audio Devices” section) showed up spontaneously, without ‘scanning’.
All devices are on the same subnet (192.168.1.XXX). All devices are physically connected via Ethernet and are, other than this problem, functioning normally.
Should the Marantz and Sony show up?
- s.west
p.s. Everything connected to the PC (where I’m running the Roon client) shows up correctly. Then, other than the two devices that I mentioned (yamaha and oppo), nothing else shows up… Should my Alexa devices appear? I don’t need them, I’m just wondering. Also, since the QNAP can render Audio and Video, I’m surprised that it doesn’t show up as a device…
[edit] Hang on, in the “Connected to Core” I think the “HDA Intel PCH” was probably the QNAP, yes? I enabled it (it says “ALSA” below it…)

Do the Sony and marantz have either Chromecast or airplay?

Ummm… I don’t know. I think the Marantz has AirPlay… I’ll go check.

Only roon ready and roon tested devices can be expected to show up. Any others may turn up.

Well, according to the Marantz website, for this model:

AirPlay Audio Streaming – Yes

So, I guess the answer is yes.

I may have to enable something on the Sony… I’ll go check on that also.

[edit] Yeah, the Sony A80J has AirPlay, and it is on (I am AirPlay illiterate, so I’m not even sure what it means for AirPlay to be “On”.)

Come to think of it, I have a couple of dedicated Chromecast devices in the house. I just checked on my phone, and started an audio app and asked it to “Cast To:” and the Chromecast devices showed up… Now these, of course, are connected to the Network via WiFi… but, same network as everything else.
These don’t show up with Roon.

Hmmm. I noticed that after 970 some of my Google Home Minis don’t show up, but I figured it was just randomness.

This is my first try at Roon (first installed 2 days ago… I gave up on Plex), so I’m not sure what to expect… But since Chromecast was asked about, specifically, I figured it should work, yes?
I may have something set up wrong, but I can’t imagine what it is.

[edit] Yes, I’m also at 970:

Version : 1.8 (build 970) stable

On the Roon Server, what should the Connected Audio Devices show? Currently it shows a native device on the QNAP (HDA Intel PCH), and nothing else. Is that correct?

I really appreciate how robust Roon’s Library Management software is. Plex was never able to fully catalog my music, especially the Mozart 225 collection. Roon has already surpassed Plex in this particular regard (although there are still, well, problems), but now it needs to be able to find all my devices… or this is all for naught, and a waste of my time, and I won’t be going past the trial period (I have 12 days left).
- s.west

are they all on the same network subnet…

personally not a fan of NAS based cores… did you follow the QNAP installation options with SSD databses location etc?

First off make sure that both Roon.exe and RAAtserver.exe are allowed as exceptions in your computer’s firewall and any any antivirus or VPN are off It will be likely some network config Roon doenst like most likely. If that’s all set check on the Netgear router for an option for Multicast and try toggling it on and off. Try also rebooting your router. Airplay relies on mdns for discovery so make sure this isn’t being blocked by the router often on some it will block multicast broadcasts that are needed for discovery over WiFi.

Both these appear to only support AirPlay 2, so Roon cannot communicate with them. In fact, only Apple devices can send to Airplay 2.

Chromecast may be your only option.

1 Like

Yes. Network is: 192.168.1.XXX

Ok… Problem resolved. It was the QNAP firewall. I’ll have to figure out what needs to be added for passthrough… (e.g. the things mentioned by @CrystalGipsy, above)

Anyone here running QNAP with Roon? And running the QNAP Firewall? Perhaps there’s a configuration file?


- s.west

[edit] After having turned off the firewall, and subsequently discovering all the missing devices, I turned the firewall back on… and the devices remained… I suppose that this suggests the ‘multicast’ failure cited above. This might mean that if I add new devices in the future, I would have to temporarily disable the QNAP’s firewall in order to discover them. However, I would still welcome some guidance on what to do with the QNAP firewall to fix this for all time.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.