Scanning for files includes ignored paths [Resolved]

I run ROCK on a NUC, my files are on a Synology NAS.
In settings --> storage --> (three dot menu) --> Edit --> ignored paths, I’ve included #recycle\ and _syncapp,
which is a folder generated by a synchronisation tool I use to automatically back up my music. The paths are separated by a semicolon, following the syntax of the folders that were already added.

Nevertheless, roon picks up files that are in these folders when forcing a manual rescan. The same is true for the pre-added folders like .temp. I tried and copied an album to a folder named .temp and forced a rescan, the album still was pickes up by roon, file info showed the file location to be in the .temp-folder.

For the files in #recycle, there are two workarounds that I’m aware of:
to disable the thrash folder on my NAS altogether or to empty it manually in DSM.

Did I miss something obvious here?

Hi @Kopftelefon ---- Thank you for the report and sharing your observation(s) with us, the feedback is appreciated.

Moving forward, I see from your report that you currently have the following exceptions listed in the “ignored paths” field:

  1. #recycle\
  2. syncapp\
  3. #recycle\

According to our knowledge base article on skipped files, the correct “directory separator(s)” must be used depending on the operating system. So for OSX and Linux a forward slash " / " must be used and on Windows a back slash " " must be used.


Hello @Eric, thanks for responding.
Does that mean that I have to adjust the syntax when migrating from windows to ROCK, because the latter is based on linux?

Having tried it, I’ll answer myself for reference:
Yes, when you switch to ROCK from a Windows installation and restore your previous database, you manually have to adjust the syntax of the ignored paths.

(this bit of information would fit nicely somewhere on the ‘Migrating to ROCK’ article in the knowledge base, wouldn’t it?)

Hi @Kopftelefon ----- Thank you for touching base with me and my apologies for the slow response.

As you have pointed out (:thumbsup: :clap:), the syntax of the “ignored paths” field does indeed need to be adjusted based on the OS. After making the suggested changes, are things functioning as expected?


Yes, they do. Thank you for pointing me in the right direction.

1 Like