Schiit Audio DAC (Bifrost Uber USB) Lossless Audio Setup [Solved]

I have my computer connected to a Schiit Audio DAC (Bifrost Uber USB) through system output. This works fine, but I can only get high quality playback, not lossless. My understanding is this is because I’m using system output (WASAPI shared mode) rather than the device exclusive. When I select the DAC and check exclusive) I get the lossless light, but no audio. Just a blue light moving back and forth on the play timeline and the seconds do not increment. Obviously it’s not playing. This is a recent Dell AIO. Is this a hardware limitation or a setup issue?

Hi @mtkupp – we’ve heard a few reports like this and we have a fix coming in our next release, which we’re expecting to go live early this week.

Once you’ve received the latest update, let us know if you’re still having any issues, and we can definitely do some deeper troubleshooting ok?


I’ll let you know after the update.

Great – thanks @mtkupp!

Still an issue on build 16. DAC works fine when set as system default, but not when assigned as exclusive device. No audio and just flips through the tracks. System default shows source as lossless but output is indicated as RoonSpeakers Streaming (high quality).

Hey @mtkupp – still having issues here? Have you tried Event Driven Mode?

No change in current build (21?)

Hey @mtkupp – still exactly like this?

We’re working on getting some Schiit hardware to our QA, but if you’re still having this issue, let me know and I’ll make sure we get some more information from you so we can figure out what’s going on here.

Thanks and sorry for the trouble!

Any chance this issue will be resolved in 1.1. I purchased a Bifrost Uber and Asgard 2 two weeks ago and notice that the issue continues. 24 bit files are being down converted to 16 bit.

Any new info about this issue?

I’m eyeing a Schiit DAC but won’t get it if it doesn’t work with Roon.



I used the bifrost & currently using the gungnir which works perfect with roon. I’m using Mac OS X Is this just a Windows issue?

Actually, my Bifrost now works perfectly now with 24 bit files on Windows. No changes were announced by the Roon team. What changed?

Hi Goalline,

1.1 and Build 55 were released. The software release notes may not have listed all bug fixes. Pleased to hear that 24 bit is working for you.

I’ll mark this thread [Solved] but if the same or a similar issue arises, please feel free to post here again or open a new Support thread.



Perfect! So it was solved in build 55. Cool. As far as I am concerned, this is solved. Thank you!