Schiit Modius not showing up in Audio via Ropieee

I have a Schiit modius that I haven’t used for a while, and decided to set it up as a roon endpoint in our dining room with a raspberry pi 4 I had sitting around. I put the latest ropieee (which I guess is only ropieeeXL now), and have not been able to get it to show up as an audio device. The ropieee shows as an endpoint in Settings > About.

Feedback id a07df170106a207a

How is the Modius connected?

If the Modius connected via USB, check the RoPieee WebUi and make sure USB audio is enabled (note I am not on RoPieeeXL so it may look a bit different for you):

If it is not connected via USB then you should be able to just play to the Ropieee (assuming the Modius is connected via a hat of some kind).

And another obvious question, is the RoPieee enabled in settings audio?

For reference, this is how my Schitt Hel shows up when connected to a RoPieee Pi4 with no hat in settings audio (note for USB audio to work on the Hel I have have to have both a power USB and an Audio usb cable connected):

The Modius manual says it can be powered by the USB data/power port unless you are using the other digital inputs, so is a little different than my Hel:

I have it connected via USB, and have the Audio USB flag enabled in the ropieee audio settings. I don’t see the ropieee at all in the roon settings audio, just in roon settings info.





Looks like it might have been either the USB cable I was using, or the USB port on the raspberry pi. I kept tinkering at it, trying different cables and ports, restarting the roon app each time, and it eventually showed up!

2 Likes